mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
106 lines
3.4 KiB
Diff
106 lines
3.4 KiB
Diff
From: Ulrich Drepper <drepper@redhat.com>
|
|
Date: Sun, 26 Jul 2009 19:55:03 +0000 (-0700)
|
|
Subject: Compatibility of signalfd/eventfd with older kernels.
|
|
X-Git-Tag: fedora/glibc-2.10.90-9~1^2~4
|
|
X-Git-Url: http://repo.or.cz/w/glibc.git?a=commitdiff_plain;h=aa7492d2
|
|
|
|
Compatibility of signalfd/eventfd with older kernels.
|
|
---
|
|
|
|
diff --git a/sysdeps/unix/sysv/linux/eventfd.c b/sysdeps/unix/sysv/linux/eventfd.c
|
|
index 4cd5579..7f69ecd 100644
|
|
--- a/sysdeps/unix/sysv/linux/eventfd.c
|
|
+++ b/sysdeps/unix/sysv/linux/eventfd.c
|
|
@@ -1,4 +1,4 @@
|
|
-/* Copyright (C) 2007, 2008 Free Software Foundation, Inc.
|
|
+/* Copyright (C) 2007, 2008, 2009 Free Software Foundation, Inc.
|
|
This file is part of the GNU C Library.
|
|
|
|
The GNU C Library is free software; you can redistribute it and/or
|
|
@@ -19,14 +19,21 @@
|
|
#include <errno.h>
|
|
#include <sys/eventfd.h>
|
|
#include <sysdep.h>
|
|
+#include <kernel-features.h>
|
|
|
|
|
|
int
|
|
eventfd (int count, int flags)
|
|
{
|
|
#ifdef __NR_eventfd2
|
|
- return INLINE_SYSCALL (eventfd2, 2, count, flags);
|
|
-#else
|
|
+ int res = INLINE_SYSCALL (eventfd2, 2, count, flags);
|
|
+# ifndef __ASSUME_EVENTFD2
|
|
+ if (res != -1 || errno != ENOSYS)
|
|
+# endif
|
|
+ return res;
|
|
+#endif
|
|
+
|
|
+#ifndef __ASSUME_EVENTFD2
|
|
/* The old system call has no flag parameter which is bad. So we have
|
|
to wait until we have to support to pass additional values to the
|
|
kernel (sys_indirect) before implementing setting flags like
|
|
@@ -43,5 +50,7 @@ eventfd (int count, int flags)
|
|
__set_errno (ENOSYS);
|
|
return -1;
|
|
# endif
|
|
+#elif !defined __NR_eventfd2
|
|
+# error "__ASSUME_EVENTFD2 defined but not __NR_eventfd2"
|
|
#endif
|
|
}
|
|
diff --git a/sysdeps/unix/sysv/linux/kernel-features.h b/sysdeps/unix/sysv/linux/kernel-features.h
|
|
index 4562515..ff065ef 100644
|
|
--- a/sysdeps/unix/sysv/linux/kernel-features.h
|
|
+++ b/sysdeps/unix/sysv/linux/kernel-features.h
|
|
@@ -516,6 +516,8 @@
|
|
# define __ASSUME_SOCK_CLOEXEC 1
|
|
# define __ASSUME_IN_NONBLOCK 1
|
|
# define __ASSUME_PIPE2 1
|
|
+# define __ASSUME_EVENTFD2 1
|
|
+# define __ASSUME_SIGNALFD4 1
|
|
#endif
|
|
|
|
/* Support for the accept4 syscall was added in 2.6.28. */
|
|
diff --git a/sysdeps/unix/sysv/linux/signalfd.c b/sysdeps/unix/sysv/linux/signalfd.c
|
|
index 9898f29..c2d974a 100644
|
|
--- a/sysdeps/unix/sysv/linux/signalfd.c
|
|
+++ b/sysdeps/unix/sysv/linux/signalfd.c
|
|
@@ -1,4 +1,4 @@
|
|
-/* Copyright (C) 2007, 2008 Free Software Foundation, Inc.
|
|
+/* Copyright (C) 2007, 2008, 2009 Free Software Foundation, Inc.
|
|
This file is part of the GNU C Library.
|
|
|
|
The GNU C Library is free software; you can redistribute it and/or
|
|
@@ -20,14 +20,21 @@
|
|
#include <signal.h>
|
|
#include <sys/signalfd.h>
|
|
#include <sysdep.h>
|
|
+#include <kernel-features.h>
|
|
|
|
|
|
int
|
|
signalfd (int fd, const sigset_t *mask, int flags)
|
|
{
|
|
#ifdef __NR_signalfd4
|
|
- return INLINE_SYSCALL (signalfd4, 4, fd, mask, _NSIG / 8, flags);
|
|
-#else
|
|
+ int res = INLINE_SYSCALL (signalfd4, 4, fd, mask, _NSIG / 8, flags);
|
|
+# ifndef __ASSUME_SIGNALFD4
|
|
+ if (res != -1 || errno != ENOSYS)
|
|
+# endif
|
|
+ return res;
|
|
+#endif
|
|
+
|
|
+#ifndef __ASSUME_SIGNALFD4
|
|
/* The old system call has no flag parameter which is bad. So we have
|
|
to wait until we have to support to pass additional values to the
|
|
kernel (sys_indirect) before implementing setting flags like
|
|
@@ -44,5 +51,7 @@ signalfd (int fd, const sigset_t *mask, int flags)
|
|
__set_errno (ENOSYS);
|
|
return -1;
|
|
# endif
|
|
+#elif !defined __NR_signalfd4
|
|
+# error "__ASSUME_SIGNALFD4 defined but not __NR_signalfd4"
|
|
#endif
|
|
}
|