PKGBUILDs/core/isdn4k-utils/gcc3.3-slashdev.patch
2009-10-09 21:17:35 -05:00

62 lines
2.7 KiB
Diff

diff -urN isdn4k-utils.orig/Makefile isdn4k-utils/Makefile
--- isdn4k-utils.orig/Makefile 2003-07-11 14:13:04.000000000 +0200
+++ isdn4k-utils/Makefile 2003-07-11 14:19:00.000000000 +0200
@@ -132,12 +132,6 @@
install: rootperm
set -e; for i in `echo $(SUBDIRS)`; do $(MAKE) -C $$i install; done
- @if [ -c $(DESTDIR)/dev/isdnctrl0 ] && ls -l $(DESTDIR)/dev/isdnctrl0 | egrep "[[:space:]]45,[[:space:]]+64[[:space:]]" > /dev/null; \
- then \
- /bin/echo -e '(some) ISDN devices already exist, not creating them.\nUse scripts/makedev.sh manually if necessary.'; \
- else \
- sh scripts/makedev.sh $(DESTDIR) ; \
- fi
uninstall: rootperm
set -e; for i in `echo $(SUBDIRS)`; do $(MAKE) -C $$i uninstall; done
diff -urN isdn4k-utils.orig/ipppd/options.c isdn4k-utils/ipppd/options.c
--- isdn4k-utils.orig/ipppd/options.c 2003-07-11 14:13:05.000000000 +0200
+++ isdn4k-utils/ipppd/options.c 2003-07-11 14:19:13.000000000 +0200
@@ -479,26 +479,24 @@
#define IMPLEMENTATION ""
#endif
-static char *usage_string = "\
-ipppd version %s patch level %d%s\n\
-Usage: %s [ options ], where options are:\n\
-\t<device> Communicate over the named device\n\
+static char *usage_string = "ipppd version %s patch level %d%s\n"
+"Usage: %s [ options ], where options are:\n"
+"\t<device> Communicate over the named device\n"
#ifdef INCLUDE_OBSOLETE_FEATURES
-\tcrtscts Use hardware RTS/CTS flow control\n\
-\t<speed> Set the baud rate to <speed>\n\
-\tmodem Use modem control lines\n\
+"\tcrtscts Use hardware RTS/CTS flow control\n"
+"\t<speed> Set the baud rate to <speed>\n"
+"\tmodem Use modem control lines\n"
#endif
-\t<loc>:<rem> Set the local and/or remote interface IP\n\
-\t\taddresses. (you also may use the option 'useifip' to get IPs).\n\
-\tasyncmap <n> Set the desired async map to hex <n>\n\
-\tauth Require authentication from peer\n\
-\tconnect <p> Invoke shell command <p> to set up the serial line\n\
-\tdefaultroute Add default route through interface\n\
-\tfile <f> Take options from file <f>\n\
-\tmru <n> Set MRU value to <n> for negotiation\n\
-\tnetmask <n> Set interface netmask to <n>\n\
-See ipppd(8) for more options.\n\
-";
+"\t<loc>:<rem> Set the local and/or remote interface IP\n"
+"\t\t\taddresses. (you also may use the option 'useifip' to get IPs).\n"
+"\tasyncmap <n> Set the desired async map to hex <n>\n"
+"\tauth Require authentication from peer\n"
+"\tconnect <p> Invoke shell command <p> to set up the serial line\n"
+"\tdefaultroute Add default route through interface\n"
+"\tfile <f> Take options from file <f>\n"
+"\tmru <n> Set MRU value to <n> for negotiation\n"
+"\tnetmask <n> Set interface netmask to <n>\n"
+"See ipppd(8) for more options.\n";
static char *current_option; /* the name of the option being parsed */