mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
14 lines
576 B
Diff
14 lines
576 B
Diff
--- Makefile.orig 2009-09-02 23:49:06.000000000 +0000
|
|
+++ Makefile 2009-09-02 23:49:40.000000000 +0000
|
|
@@ -565,6 +565,11 @@
|
|
# disable pointer signed / unsigned warnings in gcc 4.0
|
|
KBUILD_CFLAGS += $(call cc-option,-Wno-pointer-sign,)
|
|
|
|
+# gcc-4.4 defaults to generating .eh_frame sections, but we aren't
|
|
+# interested in those currently. additionally, it causes issues on some
|
|
+# architectures.
|
|
+KBUILD_CFLAGS += $(call cc-option,-fno-dwarf2-cfi-asm)
|
|
+
|
|
# Add user supplied CPPFLAGS, AFLAGS and CFLAGS as the last assignments
|
|
# But warn user when we do so
|
|
warn-assign = \
|