mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
15 lines
860 B
Diff
15 lines
860 B
Diff
X-Git-Url: http://git.savannah.gnu.org/gitweb/?p=libcdio.git;a=blobdiff_plain;f=lib%2Fdriver%2Fgnu_linux.c;h=092af0d661ecb2c3e9435f0847017e1ff36040ba;hp=7e2f3c449de78af0004dd07ef3b243333bc3a401;hb=7c497a2c735b695cdbedc3cfb80348bad847ba00;hpb=37f248aa4685cae0187f3e100623a94320944251
|
|
|
|
diff --git a/lib/driver/gnu_linux.c b/lib/driver/gnu_linux.c
|
|
index 7e2f3c4..092af0d 100644
|
|
--- a/lib/driver/gnu_linux.c
|
|
+++ b/lib/driver/gnu_linux.c
|
|
@@ -1448,7 +1448,7 @@ cdio_get_default_device_linux(void)
|
|
/* Scan the system for CD-ROM drives.
|
|
Not always 100% reliable, so use the USE_MNTENT code above first.
|
|
*/
|
|
- for ( i=0; checklist2[i].format; ++i ) {
|
|
+ for ( i=0; i < checklist2_size; ++i ) {
|
|
unsigned int j;
|
|
for ( j=checklist2[i].num_min; j<=checklist2[i].num_max; ++j ) {
|
|
if (snprintf(drive, sizeof(drive), checklist2[i].format, j) < 0)
|