mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
62 lines
2.5 KiB
Diff
62 lines
2.5 KiB
Diff
From 664a93d409133ee914d9df04041b78102c1f9e02 Mon Sep 17 00:00:00 2001
|
|
From: Nikita Popov <npopov@redhat.com>
|
|
Date: Fri, 19 Jan 2024 15:19:58 +0100
|
|
Subject: [PATCH] Fix build with GCC 14 on ARM (#78704)
|
|
|
|
GCC 14 defines `__arm_streaming` as a macro expanding to
|
|
`[[arm::streaming]]`. Due to the nested macro use, this gets expanded
|
|
prior to concatenation.
|
|
|
|
It doesn't look like C++ has a really clean way to prevent macro
|
|
expansion. The best I have found is to use `EMPTY ## X` where `EMPTY` is
|
|
an empty macro argument, so this is the hack I'm implementing here.
|
|
|
|
Fixes https://github.com/llvm/llvm-project/issues/78691.
|
|
---
|
|
clang/include/clang/Basic/TokenKinds.def | 2 +-
|
|
clang/include/clang/Basic/TokenKinds.h | 2 +-
|
|
clang/utils/TableGen/ClangAttrEmitter.cpp | 2 +-
|
|
3 files changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/clang/include/clang/Basic/TokenKinds.def b/clang/include/clang/Basic/TokenKinds.def
|
|
index ef0dad0f2..afd101b00 100644
|
|
--- a/clang/include/clang/Basic/TokenKinds.def
|
|
+++ b/clang/include/clang/Basic/TokenKinds.def
|
|
@@ -753,7 +753,7 @@ KEYWORD(__builtin_sycl_unique_stable_name, KEYSYCL)
|
|
|
|
// Keywords defined by Attr.td.
|
|
#ifndef KEYWORD_ATTRIBUTE
|
|
-#define KEYWORD_ATTRIBUTE(X) KEYWORD(X, KEYALL)
|
|
+#define KEYWORD_ATTRIBUTE(X, EMPTY) KEYWORD(EMPTY ## X, KEYALL)
|
|
#endif
|
|
#include "clang/Basic/AttrTokenKinds.inc"
|
|
|
|
diff --git a/clang/include/clang/Basic/TokenKinds.h b/clang/include/clang/Basic/TokenKinds.h
|
|
index e4857405b..ff117bd5a 100644
|
|
--- a/clang/include/clang/Basic/TokenKinds.h
|
|
+++ b/clang/include/clang/Basic/TokenKinds.h
|
|
@@ -109,7 +109,7 @@ bool isPragmaAnnotation(TokenKind K);
|
|
|
|
inline constexpr bool isRegularKeywordAttribute(TokenKind K) {
|
|
return (false
|
|
-#define KEYWORD_ATTRIBUTE(X) || (K == tok::kw_##X)
|
|
+#define KEYWORD_ATTRIBUTE(X, ...) || (K == tok::kw_##X)
|
|
#include "clang/Basic/AttrTokenKinds.inc"
|
|
);
|
|
}
|
|
diff --git a/clang/utils/TableGen/ClangAttrEmitter.cpp b/clang/utils/TableGen/ClangAttrEmitter.cpp
|
|
index b5813c6ab..79db17501 100644
|
|
--- a/clang/utils/TableGen/ClangAttrEmitter.cpp
|
|
+++ b/clang/utils/TableGen/ClangAttrEmitter.cpp
|
|
@@ -3430,7 +3430,7 @@ void EmitClangAttrTokenKinds(RecordKeeper &Records, raw_ostream &OS) {
|
|
"RegularKeyword attributes with arguments are not "
|
|
"yet supported");
|
|
OS << "KEYWORD_ATTRIBUTE("
|
|
- << S.getSpellingRecord().getValueAsString("Name") << ")\n";
|
|
+ << S.getSpellingRecord().getValueAsString("Name") << ", )\n";
|
|
}
|
|
OS << "#undef KEYWORD_ATTRIBUTE\n";
|
|
}
|
|
--
|
|
2.36.1
|
|
|