mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
59 lines
1.6 KiB
Diff
59 lines
1.6 KiB
Diff
From 02714f8c47a6500209907afcc6faf8823e55c0ca Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Mon, 14 Aug 2017 18:37:05 -0600
|
|
Subject: [PATCH] arch linux arm modifications
|
|
|
|
---
|
|
configs/am335x_boneblack_defconfig | 1 -
|
|
include/configs/am335x_evm.h | 8 +++++---
|
|
2 files changed, 5 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/configs/am335x_boneblack_defconfig b/configs/am335x_boneblack_defconfig
|
|
index 3d86c1b34e..b8a72e57df 100644
|
|
--- a/configs/am335x_boneblack_defconfig
|
|
+++ b/configs/am335x_boneblack_defconfig
|
|
@@ -5,7 +5,6 @@ CONFIG_AM33XX=y
|
|
# CONFIG_SPL_NAND_SUPPORT is not set
|
|
CONFIG_SPL_STACK_R_ADDR=0x82000000
|
|
CONFIG_DISTRO_DEFAULTS=y
|
|
-CONFIG_SYS_EXTRA_OPTIONS="EMMC_BOOT"
|
|
CONFIG_SYS_CONSOLE_INFO_QUIET=y
|
|
CONFIG_VERSION_VARIABLE=y
|
|
CONFIG_ARCH_MISC_INIT=y
|
|
diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
|
|
index 0c6d2880da..9afc46411d 100644
|
|
--- a/include/configs/am335x_evm.h
|
|
+++ b/include/configs/am335x_evm.h
|
|
@@ -17,6 +17,7 @@
|
|
#define __CONFIG_AM335X_EVM_H
|
|
|
|
#include <configs/ti_am335x_common.h>
|
|
+#define CONFIG_ENV_IS_NOWHERE
|
|
|
|
#ifndef CONFIG_SPL_BUILD
|
|
# define CONFIG_TIMESTAMP
|
|
@@ -76,10 +77,7 @@
|
|
|
|
#define BOOT_TARGET_DEVICES(func) \
|
|
func(MMC, mmc, 0) \
|
|
- func(LEGACY_MMC, legacy_mmc, 0) \
|
|
func(MMC, mmc, 1) \
|
|
- func(LEGACY_MMC, legacy_mmc, 1) \
|
|
- func(NAND, nand, 0) \
|
|
func(PXE, pxe, na) \
|
|
func(DHCP, dhcp, na)
|
|
|
|
@@ -87,6 +85,10 @@
|
|
"if test ${boot_fit} -eq 1; then " \
|
|
"run update_to_fit;" \
|
|
"fi;" \
|
|
+ "gpio clear 54; " \
|
|
+ "gpio clear 55; " \
|
|
+ "gpio clear 56; " \
|
|
+ "gpio set 53; " \
|
|
"run findfdt; " \
|
|
"run init_console; " \
|
|
"run envboot; " \
|
|
--
|
|
2.14.1
|
|
|