mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
bda45916e1
and check dtbs dir for dtb file
61 lines
1.8 KiB
Diff
61 lines
1.8 KiB
Diff
From 52422e37bb199fa5c62881cdf26c687aa692d063 Mon Sep 17 00:00:00 2001
|
|
From: Jeroen Hofstee <jeroen@myspectrum.nl>
|
|
Date: Wed, 8 Oct 2014 22:57:53 +0200
|
|
Subject: [PATCH] leds: missing include
|
|
|
|
Signed-off-by: Jeroen Hofstee <jeroen@myspectrum.nl>
|
|
---
|
|
arch/arm/cpu/arm926ejs/at91/led.c | 1 +
|
|
arch/arm/lib/board.c | 1 +
|
|
board/atmel/at91rm9200ek/led.c | 1 +
|
|
board/atmel/at91sam9260ek/led.c | 1 +
|
|
4 files changed, 4 insertions(+)
|
|
|
|
diff --git a/arch/arm/cpu/arm926ejs/at91/led.c b/arch/arm/cpu/arm926ejs/at91/led.c
|
|
index 46ed055..b8d5c78 100644
|
|
--- a/arch/arm/cpu/arm926ejs/at91/led.c
|
|
+++ b/arch/arm/cpu/arm926ejs/at91/led.c
|
|
@@ -9,6 +9,7 @@
|
|
#include <common.h>
|
|
#include <asm/gpio.h>
|
|
#include <asm/arch/gpio.h>
|
|
+#include <status_led.h>
|
|
|
|
#ifdef CONFIG_RED_LED
|
|
void red_led_on(void)
|
|
diff --git a/arch/arm/lib/board.c b/arch/arm/lib/board.c
|
|
index 98782ca..f606255 100644
|
|
--- a/arch/arm/lib/board.c
|
|
+++ b/arch/arm/lib/board.c
|
|
@@ -34,6 +34,7 @@
|
|
#include <nand.h>
|
|
#include <onenand_uboot.h>
|
|
#include <mmc.h>
|
|
+#include <status_led.h>
|
|
#include <libfdt.h>
|
|
#include <fdtdec.h>
|
|
#include <post.h>
|
|
diff --git a/board/atmel/at91rm9200ek/led.c b/board/atmel/at91rm9200ek/led.c
|
|
index 2298e36..6761b14 100644
|
|
--- a/board/atmel/at91rm9200ek/led.c
|
|
+++ b/board/atmel/at91rm9200ek/led.c
|
|
@@ -14,6 +14,7 @@
|
|
#include <asm/arch/hardware.h>
|
|
#include <asm/arch/at91_pmc.h>
|
|
#include <asm/arch/at91_pio.h>
|
|
+#include <status_led.h>
|
|
|
|
/* bit mask in PIO port B */
|
|
#define GREEN_LED (1<<0)
|
|
diff --git a/board/atmel/at91sam9260ek/led.c b/board/atmel/at91sam9260ek/led.c
|
|
index 56d811c..fbe15af 100644
|
|
--- a/board/atmel/at91sam9260ek/led.c
|
|
+++ b/board/atmel/at91sam9260ek/led.c
|
|
@@ -9,6 +9,7 @@
|
|
#include <common.h>
|
|
#include <asm/io.h>
|
|
#include <asm/arch/gpio.h>
|
|
+#include <status_led.h>
|
|
|
|
void coloured_LED_init(void)
|
|
{
|