PKGBUILDs/core/mkinitcpio/0001-use-gzip-for-compression-by-default.patch
2023-11-16 20:07:08 +00:00

54 lines
2.1 KiB
Diff

From 3ceb9e3e9624a8c7915f086eeb17813453a25acc Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 20 Feb 2021 10:02:34 -0700
Subject: [PATCH 1/3] use gzip for compression by default
---
man/mkinitcpio.conf.5.adoc | 2 +-
mkinitcpio | 2 +-
mkinitcpio.conf | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/man/mkinitcpio.conf.5.adoc b/man/mkinitcpio.conf.5.adoc
index 69bbc6a..ad60b6b 100644
--- a/man/mkinitcpio.conf.5.adoc
+++ b/man/mkinitcpio.conf.5.adoc
@@ -55,7 +55,7 @@ override the main configuration file.
Defines a program to filter the generated image through. The kernel
understands the compression formats yielded by the *zstd*(1), *gzip*(1),
*bzip2*(1), *lz4*(1), *lzop*(1), *lzma*(1), and *xz*(1) compressors. If
- unspecified, this setting defaults to _zstd_ compression. In order to create
+ unspecified, this setting defaults to _gzip_ compression. In order to create
an uncompressed image, define this variable as _cat_.
+
It is not hard to realize that a filter such as a _tac_ or _rev_ will cause
diff --git a/mkinitcpio b/mkinitcpio
index b758f85..98a80e0 100755
--- a/mkinitcpio
+++ b/mkinitcpio
@@ -952,7 +952,7 @@ if [[ -n "$_optgenimg" ]]; then
die "Unable to write to '%s'" "$_optgenimg"
fi
- _optcompress="${_optcompress:-"${COMPRESSION:-zstd}"}"
+ _optcompress="${_optcompress:-"${COMPRESSION:-gzip}"}"
if ! type -P "$_optcompress" >/dev/null; then
warning "Unable to locate compression method: '%s'" "$_optcompress"
_optcompress='cat'
diff --git a/mkinitcpio.conf b/mkinitcpio.conf
index 710e05f..4a2ce87 100644
--- a/mkinitcpio.conf
+++ b/mkinitcpio.conf
@@ -52,7 +52,7 @@ FILES=()
HOOKS=(base udev autodetect modconf kms keyboard keymap consolefont block filesystems fsck)
# COMPRESSION
-# Use this to compress the initramfs image. By default, zstd compression
+# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="zstd"
#COMPRESSION="gzip"
--
2.36.1