mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
364 lines
7.3 KiB
Diff
364 lines
7.3 KiB
Diff
diff -Naur a/arch/arm/boot/dts/kirkwood-nsa325.dts b/arch/arm/boot/dts/kirkwood-nsa325.dts
|
|
--- a/arch/arm/boot/dts/kirkwood-nsa325.dts 1969-12-31 16:00:00.000000000 -0800
|
|
+++ b/arch/arm/boot/dts/kirkwood-nsa325.dts 2014-10-18 18:36:44.000000000 -0700
|
|
@@ -0,0 +1,360 @@
|
|
+/*
|
|
+ * Device tree file for Zyxel NSA 325 NAS
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include "kirkwood.dtsi"
|
|
+#include "kirkwood-6282.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "ZyXEL NSA325";
|
|
+ compatible = "zyxel,nsa325", "marvell,kirkwood-88f6282", "marvell,kirkwood";
|
|
+
|
|
+ memory {
|
|
+ device_type = "memory";
|
|
+ reg = <0x00000000 0x20000000>;
|
|
+ };
|
|
+
|
|
+ chosen {
|
|
+ bootargs = "console=ttyS0,115200";
|
|
+ stdout-path = &uart0;
|
|
+ };
|
|
+
|
|
+ mbus {
|
|
+ pcie-controller {
|
|
+ status = "okay";
|
|
+
|
|
+ pcie@1,0 {
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ ocp@f1000000 {
|
|
+ pinctrl: pin-controller@10000 {
|
|
+ pinctrl-names = "default";
|
|
+
|
|
+ pmx_led_sata2_green: pmx-led-sata2-green {
|
|
+ marvell,pins = "mpp12";
|
|
+ marvell,function = "gpo";
|
|
+ };
|
|
+
|
|
+ pmx_led_sata2_red: pmx-led-sata2-red {
|
|
+ marvell,pins = "mpp13";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_mcu_data: pmx-mcu-data {
|
|
+ marvell,pins = "mpp14";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_led_usb_green: pmx-led-usb-green {
|
|
+ marvell,pins = "mpp15";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_mcu_clk: pmx-mcu-clk {
|
|
+ marvell,pins = "mpp16";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_mcu_act: pmx-mcu-act {
|
|
+ marvell,pins = "mpp17";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_usb_power_off: pmx-usb-power-off {
|
|
+ marvell,pins = "mpp21";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_led_sys_green: pmx-led-sys-green {
|
|
+ marvell,pins = "mpp28";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_led_sys_orange: pmx-led-sys-orange {
|
|
+ marvell,pins = "mpp29";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_btn_reset: pmx-btn-reset {
|
|
+ marvell,pins = "mpp36";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_btn_copy: pmx-btn-copy {
|
|
+ marvell,pins = "mpp37";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_led_copy_green: pmx-led-copy-green {
|
|
+ marvell,pins = "mpp39";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_led_copy_red: pmx-led-copy-red {
|
|
+ marvell,pins = "mpp40";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_led_sata1_green: pmx-led-sata1-green {
|
|
+ marvell,pins = "mpp41";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_led_sata1_red: pmx-led-sata1-red {
|
|
+ marvell,pins = "mpp42";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_beeper: pmx-beeper {
|
|
+ marvell,pins = "mpp44";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_btn_power: pmx-btn-power {
|
|
+ marvell,pins = "mpp46";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_pwr_sata1: pmx-pwr-sata1 {
|
|
+ marvell,pins = "mpp47";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+
|
|
+ pmx_pwr_off: pmx-pwr-off {
|
|
+ marvell,pins = "mpp48";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ /* This board uses the pcf8563 RTC instead of the SoC RTC */
|
|
+ rtc@10300 {
|
|
+ status = "disabled";
|
|
+ };
|
|
+
|
|
+ i2c@11000 {
|
|
+ status = "okay";
|
|
+
|
|
+ pcf8563: pcf8563@51 {
|
|
+ compatible = "nxp,pcf8563";
|
|
+ reg = <0x51>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ serial@12000 {
|
|
+ status = "ok";
|
|
+ };
|
|
+
|
|
+ sata@80000 {
|
|
+ status = "okay";
|
|
+ nr-ports = <2>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ gpio_keys {
|
|
+ compatible = "gpio-keys";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ pinctrl-0 = <&pmx_btn_power &pmx_btn_copy &pmx_btn_reset>;
|
|
+ pinctrl-names = "default";
|
|
+
|
|
+ button@1 {
|
|
+ label = "Power Button";
|
|
+ linux,code = <KEY_POWER>;
|
|
+ gpios = <&gpio1 14 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ button@2 {
|
|
+ label = "Copy Button";
|
|
+ linux,code = <KEY_COPY>;
|
|
+ gpios = <&gpio1 5 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+
|
|
+ button@3 {
|
|
+ label = "Reset Button";
|
|
+ linux,code = <KEY_RESTART>;
|
|
+ gpios = <&gpio1 4 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ gpio-leds {
|
|
+ compatible = "gpio-leds";
|
|
+ pinctrl-0 = <&pmx_led_sata1_green &pmx_led_sata1_red
|
|
+ &pmx_led_sata2_green &pmx_led_sata2_red
|
|
+ &pmx_led_sys_green &pmx_led_sys_orange
|
|
+ &pmx_led_copy_green &pmx_led_copy_red
|
|
+ &pmx_led_usb_green>;
|
|
+ pinctrl-names = "default";
|
|
+
|
|
+ green-sata2 {
|
|
+ label = "nsa325:green:sata2";
|
|
+ gpios = <&gpio0 12 GPIO_ACTIVE_HIGH>;
|
|
+ linux,default-trigger = "ide-disk2";
|
|
+ };
|
|
+
|
|
+ red-sata2 {
|
|
+ label = "nsa325:red:sata2";
|
|
+ gpios = <&gpio0 13 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ green-usb {
|
|
+ label = "nsa325:green:usb";
|
|
+ gpios = <&gpio0 15 GPIO_ACTIVE_HIGH>;
|
|
+ linux,default-trigger = "usb-host";
|
|
+ };
|
|
+
|
|
+ green-sys {
|
|
+ label = "nsa325:green:sys";
|
|
+ gpios = <&gpio0 28 GPIO_ACTIVE_HIGH>;
|
|
+ linux,default-trigger = "default-on";
|
|
+ };
|
|
+
|
|
+ orange-sys {
|
|
+ label = "nsa325:orange:sys";
|
|
+ gpios = <&gpio0 29 GPIO_ACTIVE_HIGH>;
|
|
+ linux,default-trigger = "cpu0";
|
|
+ };
|
|
+
|
|
+ green-copy {
|
|
+ label = "nsa325:green:copy";
|
|
+ gpios = <&gpio1 7 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ red-copy {
|
|
+ label = "nsa325:red:copy";
|
|
+ gpios = <&gpio1 8 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ green-sata1 {
|
|
+ label = "nsa325:green:sata1";
|
|
+ gpios = <&gpio1 9 GPIO_ACTIVE_HIGH>;
|
|
+ linux,default-trigger = "ide-disk1";
|
|
+ };
|
|
+
|
|
+ red-sata1 {
|
|
+ label = "nsa325:red:sata1";
|
|
+ gpios = <&gpio1 10 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ gpio_poweroff {
|
|
+ compatible = "gpio-poweroff";
|
|
+ pinctrl-0 = <&pmx_pwr_off>;
|
|
+ pinctrl-names = "default";
|
|
+ gpios = <&gpio1 16 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ regulators {
|
|
+ compatible = "simple-bus";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ pinctrl-0 = <&pmx_mcu_data &pmx_usb_power_off &pmx_pwr_sata1>;
|
|
+ pinctrl-names = "default";
|
|
+
|
|
+/*
|
|
+ watchdog_data: regulator@1 {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "Watchdog Data";
|
|
+ regulator-min-microvolt = <5000000>;
|
|
+ regulator-max-microvolt = <5000000>;
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ gpio = <&gpio0 14 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+*/
|
|
+
|
|
+ usb_power: regulator@2 {
|
|
+ compatible = "regulator-fixed";
|
|
+ reg = <2>;
|
|
+ regulator-name = "USB Power";
|
|
+ regulator-min-microvolt = <5000000>;
|
|
+ regulator-max-microvolt = <5000000>;
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ enable-active-high;
|
|
+ gpio = <&gpio0 21 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ sata1_power: regulator@3 {
|
|
+ compatible = "regulator-fixed";
|
|
+ reg = <3>;
|
|
+ regulator-name = "SATA1 Power";
|
|
+ regulator-min-microvolt = <5000000>;
|
|
+ regulator-max-microvolt = <5000000>;
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ enable-active-high;
|
|
+ gpio = <&gpio1 15 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&nand {
|
|
+ status = "okay";
|
|
+ chip-delay = <35>;
|
|
+
|
|
+ partition@0 {
|
|
+ label = "uboot";
|
|
+ reg = <0x0000000 0x0100000>;
|
|
+ };
|
|
+
|
|
+ partition@100000 {
|
|
+ label = "uboot_env";
|
|
+ reg = <0x0100000 0x0080000>;
|
|
+ };
|
|
+
|
|
+ partition@180000 {
|
|
+ label = "key_store";
|
|
+ reg = <0x0180000 0x0080000>;
|
|
+ };
|
|
+
|
|
+ partition@200000 {
|
|
+ label = "info";
|
|
+ reg = <0x0200000 0x0080000>;
|
|
+ };
|
|
+
|
|
+ partition@280000 {
|
|
+ label = "etc";
|
|
+ reg = <0x0280000 0x0a00000>;
|
|
+ };
|
|
+
|
|
+ partition@c80000 {
|
|
+ label = "kernel_1";
|
|
+ reg = <0x0c80000 0x0a00000>;
|
|
+ };
|
|
+
|
|
+ partition@1680000 {
|
|
+ label = "rootfs1";
|
|
+ reg = <0x1680000 0x2fc0000>;
|
|
+ };
|
|
+
|
|
+ partition@4640000 {
|
|
+ label = "kernel_2";
|
|
+ reg = <0x4640000 0x0a00000>;
|
|
+ };
|
|
+
|
|
+ partition@5040000 {
|
|
+ label = "rootfs2";
|
|
+ reg = <0x5040000 0x2fc0000>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&mdio {
|
|
+ status = "okay";
|
|
+
|
|
+ ethphy0: ethernet-phy@1 {
|
|
+ reg = <1>;
|
|
+ };
|
|
+};
|
|
+
|
|
+ð0 {
|
|
+ status = "okay";
|
|
+
|
|
+ ethernet0-port@0 {
|
|
+ phy-handle = <ðphy0>;
|
|
+ };
|
|
+};
|