mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
132 lines
3.5 KiB
Diff
132 lines
3.5 KiB
Diff
diff -uprN a/arch/arm/boot/dts/kirkwood-pogo_e02.dts b/arch/arm/boot/dts/kirkwood-pogo_e02.dts
|
|
--- a/arch/arm/boot/dts/kirkwood-pogo_e02.dts 1969-12-31 17:00:00.000000000 -0700
|
|
+++ b/arch/arm/boot/dts/kirkwood-pogo_e02.dts 2014-08-10 03:59:10.616338535 -0600
|
|
@@ -0,0 +1,117 @@
|
|
+/dts-v1/;
|
|
+
|
|
+#include "kirkwood.dtsi"
|
|
+#include "kirkwood-6281.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "CloudEngines Pogoplug E02";
|
|
+ compatible = "cloudengines,pogo_e02", "marvell,kirkwood-88f6281", "marvell,kirkwood";
|
|
+
|
|
+ memory {
|
|
+ device_type = "memory";
|
|
+ reg = <0x00000000 0x10000000>;
|
|
+ };
|
|
+
|
|
+ chosen {
|
|
+ bootargs = "console=ttyS0,115200n8 earlyprintk root=/dev/sda1 rootdelay=10";
|
|
+ stdout-path = &uart0;
|
|
+ };
|
|
+
|
|
+ ocp@f1000000 {
|
|
+ pinctrl: pin-controller@10000 {
|
|
+ pmx_usb_power_enable: pmx-usb-power-enable {
|
|
+ marvell,pins = "mpp29";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+ pmx_led_green: pmx-led_green {
|
|
+ marvell,pins = "mpp48";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+ pmx_led_orange: pmx-led_orange {
|
|
+ marvell,pins = "mpp49";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+ };
|
|
+ serial@12000 {
|
|
+ status = "ok";
|
|
+ };
|
|
+
|
|
+ };
|
|
+ gpio-leds {
|
|
+ compatible = "gpio-leds";
|
|
+ pinctrl-0 = < &pmx_led_orange
|
|
+ &pmx_led_green
|
|
+ >;
|
|
+ pinctrl-names = "default";
|
|
+
|
|
+ health {
|
|
+ label = "status:green:health";
|
|
+ gpios = <&gpio1 16 GPIO_ACTIVE_LOW>;
|
|
+ default-state = "keep";
|
|
+ };
|
|
+ fault {
|
|
+ label = "status:orange:fault";
|
|
+ gpios = <&gpio1 17 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+ };
|
|
+ regulators {
|
|
+ compatible = "simple-bus";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ pinctrl-0 = <&pmx_usb_power_enable>;
|
|
+ pinctrl-names = "default";
|
|
+
|
|
+ usb_power: regulator@1 {
|
|
+ compatible = "regulator-fixed";
|
|
+ reg = <1>;
|
|
+ regulator-name = "USB Power";
|
|
+ regulator-min-microvolt = <5000000>;
|
|
+ regulator-max-microvolt = <5000000>;
|
|
+ enable-active-high;
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ gpio = <&gpio0 29 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&nand {
|
|
+ chip-delay = <25>;
|
|
+ status = "okay";
|
|
+
|
|
+ partition@0 {
|
|
+ label = "u-boot";
|
|
+ reg = <0x0000000 0x100000>;
|
|
+ read-only;
|
|
+ };
|
|
+
|
|
+ partition@100000 {
|
|
+ label = "uImage";
|
|
+ reg = <0x0100000 0x0500000>;
|
|
+ };
|
|
+
|
|
+ partition@0500000 {
|
|
+ label = "pogoplug";
|
|
+ reg = <0x0500000 0x2500000>;
|
|
+ };
|
|
+
|
|
+ partition@2500000 {
|
|
+ label = "root";
|
|
+ reg = <0x2500000 0x6c00000>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&mdio {
|
|
+ status = "okay";
|
|
+
|
|
+ ethphy0: ethernet-phy@0 {
|
|
+ reg = <0>;
|
|
+ };
|
|
+};
|
|
+
|
|
+ð0 {
|
|
+ status = "okay";
|
|
+ ethernet0-port@0 {
|
|
+ phy-handle = <ðphy0>;
|
|
+ };
|
|
+};
|
|
diff -uprN a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
|
--- a/arch/arm/boot/dts/Makefile 2014-08-10 03:54:22.764885366 -0600
|
|
+++ b/arch/arm/boot/dts/Makefile 2014-08-10 04:00:43.570037020 -0600
|
|
@@ -137,6 +137,7 @@ kirkwood := \
|
|
kirkwood-openrd-base.dtb \
|
|
kirkwood-openrd-client.dtb \
|
|
kirkwood-openrd-ultimate.dtb \
|
|
+ kirkwood-pogo_e02.dtb \
|
|
kirkwood-rd88f6192.dtb \
|
|
kirkwood-rd88f6281-a0.dtb \
|
|
kirkwood-rd88f6281-a1.dtb \
|