mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
30 lines
1,011 B
Diff
30 lines
1,011 B
Diff
From 8dbce34b0373923c7aa7d795024bbedb0a85c7ea Mon Sep 17 00:00:00 2001
|
|
From: Peter Hutterer <peter.hutterer@who-t.net>
|
|
Date: Thu, 22 Jan 2015 11:36:02 +1000
|
|
Subject: [PATCH] logind: fix sd_eviocrevoke ioctl call
|
|
|
|
If the third argument is non-null, the kernel will always error out with
|
|
EINVAL and devices won't get revoked.
|
|
|
|
Reported-by: Benjamin Tissoires <benjamin.tissoires@gmail.com>
|
|
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
|
|
---
|
|
src/login/logind-session-device.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/login/logind-session-device.c b/src/login/logind-session-device.c
|
|
index 932abb8..c2de862 100644
|
|
--- a/src/login/logind-session-device.c
|
|
+++ b/src/login/logind-session-device.c
|
|
@@ -107,7 +107,7 @@ static int sd_eviocrevoke(int fd) {
|
|
|
|
assert(fd >= 0);
|
|
|
|
- r = ioctl(fd, EVIOCREVOKE, 1);
|
|
+ r = ioctl(fd, EVIOCREVOKE, NULL);
|
|
if (r < 0) {
|
|
r = -errno;
|
|
if (r == -EINVAL && !warned) {
|
|
--
|
|
2.3.0
|
|
|