PKGBUILDs/community/higan/higan-flags.patch
2017-12-28 00:09:09 +00:00

50 lines
1.6 KiB
Diff
Executable file

diff -rupN higan_v106-source.orig/higan/GNUmakefile higan_v106-source/higan/GNUmakefile
--- higan_v106-source.orig/higan/GNUmakefile 2017-12-27 23:12:21.263872763 +0100
+++ higan_v106-source/higan/GNUmakefile 2017-12-27 23:12:30.243627883 +0100
@@ -1,4 +1,4 @@
-build := optimize
+build := release
include ../nall/GNUmakefile
binary := application
@@ -26,7 +26,6 @@ else ifneq ($(filter $(platform),linux b
flags += -fopenmp
link += -fopenmp
ifeq ($(binary),application)
- flags += -march=native
link += -Wl,-export-dynamic
link += -lX11 -lXext
else ifeq ($(binary),library)
diff -rupN higan_v106-source.orig/icarus/GNUmakefile higan_v106-source/icarus/GNUmakefile
--- higan_v106-source.orig/icarus/GNUmakefile 2017-12-27 23:12:21.280538976 +0100
+++ higan_v106-source/icarus/GNUmakefile 2017-12-27 23:12:30.243627883 +0100
@@ -1,4 +1,4 @@
-build := optimize
+build := release
include ../nall/GNUmakefile
include ../hiro/GNUmakefile
diff -rupN higan_v106-source.orig/nall/GNUmakefile higan_v106-source/nall/GNUmakefile
--- higan_v106-source.orig/nall/GNUmakefile 2017-12-27 23:12:21.283872217 +0100
+++ higan_v106-source/nall/GNUmakefile 2017-12-27 23:12:44.326577547 +0100
@@ -40,8 +40,8 @@ cflags := -x c -std=c11
objcflags := -x objective-c -std=c11
cppflags := -x c++ -std=c++14
objcppflags := -x objective-c++ -std=c++14
-flags :=
-link :=
+flags := $(CXXFLAGS)
+link := $(LDFLAGS)
# compiler detection
ifeq ($(compiler),)
@@ -120,7 +120,7 @@ ifeq ($(threaded),true)
endif
# paths
-prefix := $(HOME)/.local
+prefix := /usr
# function rwildcard(directory, pattern)
rwildcard = \