mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
62 lines
2 KiB
Diff
62 lines
2 KiB
Diff
From 594e6b23a430d13922f438d955030ceacfcc6833 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Wed, 16 Mar 2016 20:06:42 -0600
|
|
Subject: [PATCH] arch linux arm modifications
|
|
|
|
---
|
|
configs/omap4_panda_defconfig | 6 +++++-
|
|
include/configs/ti_omap4_common.h | 5 ++---
|
|
2 files changed, 7 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/configs/omap4_panda_defconfig b/configs/omap4_panda_defconfig
|
|
index 8d9024854e..e1e9d00fe6 100644
|
|
--- a/configs/omap4_panda_defconfig
|
|
+++ b/configs/omap4_panda_defconfig
|
|
@@ -10,6 +10,10 @@ CONFIG_SYS_CONSOLE_INFO_QUIET=y
|
|
CONFIG_VERSION_VARIABLE=y
|
|
CONFIG_SPL=y
|
|
CONFIG_SPL_OS_BOOT=y
|
|
+CONFIG_AUTOBOOT_KEYED=y
|
|
+CONFIG_AUTOBOOT_PROMPT="Press SPACE to abort autoboot in %d seconds\n"
|
|
+CONFIG_AUTOBOOT_DELAY_STR="d"
|
|
+CONFIG_AUTOBOOT_STOP_STR=" "
|
|
# CONFIG_CMD_IMLS is not set
|
|
CONFIG_CMD_ASKENV=y
|
|
# CONFIG_CMD_FLASH is not set
|
|
@@ -20,8 +24,8 @@ CONFIG_CMD_USB=y
|
|
CONFIG_CMD_GPIO=y
|
|
# CONFIG_CMD_SETEXPR is not set
|
|
# CONFIG_CMD_NFS is not set
|
|
-CONFIG_CMD_EXT4_WRITE=y
|
|
CONFIG_SYS_NS16550=y
|
|
CONFIG_USB=y
|
|
CONFIG_USB_STORAGE=y
|
|
CONFIG_OF_LIBFDT=y
|
|
+CONFIG_IDENT_STRING=" Arch Linux ARM"
|
|
diff --git a/include/configs/ti_omap4_common.h b/include/configs/ti_omap4_common.h
|
|
index 8e0f9eb964..e718686580 100644
|
|
--- a/include/configs/ti_omap4_common.h
|
|
+++ b/include/configs/ti_omap4_common.h
|
|
@@ -42,7 +42,7 @@
|
|
* the timings to use or use pre-determined timings (based on using the
|
|
* dynamic method. Default to the static timing infomation.
|
|
*/
|
|
-#define CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS
|
|
+/*#define CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS*/
|
|
#ifndef CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS
|
|
#define CONFIG_SYS_AUTOMATIC_SDRAM_DETECTION
|
|
#define CONFIG_SYS_DEFAULT_LPDDR2_TIMINGS
|
|
@@ -91,9 +91,8 @@
|
|
|
|
#define BOOT_TARGET_DEVICES(func) \
|
|
func(MMC, mmc, 0) \
|
|
- func(LEGACY_MMC, legacy_mmc, 0) \
|
|
func(MMC, mmc, 1) \
|
|
- func(LEGACY_MMC, legacy_mmc, 1) \
|
|
+ func(USB, usb, 0) \
|
|
func(PXE, pxe, na) \
|
|
func(DHCP, dhcp, na)
|
|
|
|
--
|
|
2.11.0
|
|
|