mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
35 lines
1.1 KiB
Diff
35 lines
1.1 KiB
Diff
From 2a7e36d70c07c43844ce257ef75ae0b067d79271 Mon Sep 17 00:00:00 2001
|
|
From: Marc Zyngier <Marc.Zyngier@arm.com>
|
|
Date: Sat, 1 Jul 2017 15:16:36 +0100
|
|
Subject: [PATCH 02/11] ARM64: dts: marvell: armada37xx: Wire PMUv3
|
|
|
|
The Cortex-A53s that power the Armada-37xx SoCs are equipped with
|
|
a PMUv3, just like most ARMv8 cores.
|
|
|
|
Advertise the PMUv3 presence in the device tree, and wire its
|
|
interrupt. This allows the perf subsystem to work correctly.
|
|
|
|
Signed-off-by: Marc Zyngier <marc.zyngier@arm.com>
|
|
---
|
|
arch/arm64/boot/dts/marvell/armada-37xx.dtsi | 5 +++++
|
|
1 file changed, 5 insertions(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
|
index b6f1e7a5e5ec..35307cd93db5 100644
|
|
--- a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
|
+++ b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
|
@@ -81,6 +81,11 @@
|
|
<GIC_PPI 10 IRQ_TYPE_LEVEL_HIGH>;
|
|
};
|
|
|
|
+ pmu {
|
|
+ compatible = "arm,armv8-pmuv3";
|
|
+ interrupts = <GIC_PPI 7 IRQ_TYPE_LEVEL_HIGH>;
|
|
+ };
|
|
+
|
|
soc {
|
|
compatible = "simple-bus";
|
|
#address-cells = <2>;
|
|
--
|
|
2.14.2
|
|
|