mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
30 lines
1.4 KiB
Diff
30 lines
1.4 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Kai-Heng Feng <kai.heng.feng@canonical.com>
|
|
Date: Thu, 29 Dec 2022 14:01:31 +0800
|
|
Subject: [PATCH] Revert "iris: Avoid abort() if kernel can't allocate memory"
|
|
|
|
This reverts commit f9d8d9acbb6a620684fb4dac4affe25816587d92.
|
|
|
|
Now ENOMEM is handled in submit_batch(), we don't need to check it for
|
|
resetting anymore.
|
|
|
|
(cherry picked from commit e6add12416315b77a420dc8ccb59307ada663a1d)
|
|
---
|
|
src/gallium/drivers/iris/iris_batch.c | 3 +--
|
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
|
|
diff --git a/src/gallium/drivers/iris/iris_batch.c b/src/gallium/drivers/iris/iris_batch.c
|
|
index 9ea1ea3f10e7..32bddb72b933 100644
|
|
--- a/src/gallium/drivers/iris/iris_batch.c
|
|
+++ b/src/gallium/drivers/iris/iris_batch.c
|
|
@@ -1103,9 +1103,8 @@ _iris_batch_flush(struct iris_batch *batch, const char *file, int line)
|
|
* with a new logical context, and inform iris_context that all state
|
|
* has been lost and needs to be re-initialized. If this succeeds,
|
|
* dubiously claim success...
|
|
- * Also handle ENOMEM here.
|
|
*/
|
|
- if ((ret == -EIO || ret == -ENOMEM) && replace_kernel_ctx(batch)) {
|
|
+ if (ret == -EIO && replace_kernel_ctx(batch)) {
|
|
if (batch->reset->reset) {
|
|
/* Tell gallium frontends the device is lost and it was our fault. */
|
|
batch->reset->reset(batch->reset->data, PIPE_GUILTY_CONTEXT_RESET);
|