mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
29 lines
780 B
Diff
29 lines
780 B
Diff
Description: Expose the ice session to allow adding candidates.
|
|
.
|
|
Ring has other ways than stun to determine its IP address.
|
|
.
|
|
See ice_transport.cpp for usage details.
|
|
Author: Stepan Salenikovich <stepan.salenikovich@savoirfairelinux.com>
|
|
|
|
--- a/pjnath/include/pjnath/ice_strans.h
|
|
+++ b/pjnath/include/pjnath/ice_strans.h
|
|
@@ -845,6 +845,8 @@ PJ_DECL(pj_status_t) pj_ice_strans_sendt
|
|
int dst_addr_len);
|
|
|
|
|
|
+PJ_DECL(pj_ice_sess *) pj_ice_strans_get_ice_sess(pj_ice_strans *ice_st);
|
|
+
|
|
/**
|
|
* @}
|
|
*/
|
|
--- a/pjnath/src/pjnath/ice_strans.c
|
|
+++ b/pjnath/src/pjnath/ice_strans.c
|
|
@@ -1243,6 +1243,11 @@ PJ_DEF(pj_status_t) pj_ice_strans_sendto
|
|
return PJ_EINVALIDOP;
|
|
}
|
|
|
|
+PJ_DECL(pj_ice_sess *) pj_ice_strans_get_ice_sess( pj_ice_strans *ice_st )
|
|
+{
|
|
+ return ice_st->ice;
|
|
+}
|
|
+
|