mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
34 lines
1.1 KiB
Diff
34 lines
1.1 KiB
Diff
From 75836b9d2071aab978ee78d7d797126a18a32052 Mon Sep 17 00:00:00 2001
|
|
From: Jan Synacek <jsynacek@redhat.com>
|
|
Date: Mon, 15 Dec 2014 10:39:00 +0100
|
|
Subject: [PATCH] systemctl: fix argument handling when invoked as "shutdown"
|
|
|
|
---
|
|
src/systemctl/systemctl.c | 4 +++-
|
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/src/systemctl/systemctl.c b/src/systemctl/systemctl.c
|
|
index 649fb5c..4c4648f 100644
|
|
--- a/src/systemctl/systemctl.c
|
|
+++ b/src/systemctl/systemctl.c
|
|
@@ -6926,7 +6926,7 @@ static int shutdown_parse_argv(int argc, char *argv[]) {
|
|
assert(argc >= 0);
|
|
assert(argv);
|
|
|
|
- while ((c = getopt_long(argc, argv, "HPrhkt:afFc", options, NULL)) >= 0)
|
|
+ while ((c = getopt_long(argc, argv, "HPrhkKt:afFc", options, NULL)) >= 0)
|
|
switch (c) {
|
|
|
|
case ARG_HELP:
|
|
@@ -6967,6 +6967,8 @@ static int shutdown_parse_argv(int argc, char *argv[]) {
|
|
|
|
case 't':
|
|
case 'a':
|
|
+ case 'f':
|
|
+ case 'F':
|
|
/* Compatibility nops */
|
|
break;
|
|
|
|
--
|
|
2.3.0
|
|
|