mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
43 lines
1.7 KiB
Diff
43 lines
1.7 KiB
Diff
From b5b80df7dafba8cafa4c6c0ba2153dfda467dfc9 Mon Sep 17 00:00:00 2001
|
|
From: Stephan Hartmann <stha09@googlemail.com>
|
|
Date: Wed, 27 Jan 2021 20:31:51 +0000
|
|
Subject: [PATCH] add dependency on opus in webcodecs
|
|
|
|
webcodecs uses opus, but dependency is missing. With unbundled
|
|
opus library build fails, because include path is incomplete.
|
|
|
|
Bug: 1169758
|
|
Change-Id: I01369364327461196a81002479636cf45017669a
|
|
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2644623
|
|
Reviewed-by: Dale Curtis <dalecurtis@chromium.org>
|
|
Commit-Queue: Dale Curtis <dalecurtis@chromium.org>
|
|
Cr-Commit-Position: refs/heads/master@{#847754}
|
|
---
|
|
third_party/blink/renderer/modules/webcodecs/BUILD.gn | 1 +
|
|
third_party/blink/renderer/modules/webcodecs/DEPS | 1 +
|
|
2 files changed, 2 insertions(+)
|
|
|
|
diff --git a/third_party/blink/renderer/modules/webcodecs/BUILD.gn b/third_party/blink/renderer/modules/webcodecs/BUILD.gn
|
|
index fdf4ca0fafc72..01a7bf809ffca 100644
|
|
--- a/third_party/blink/renderer/modules/webcodecs/BUILD.gn
|
|
+++ b/third_party/blink/renderer/modules/webcodecs/BUILD.gn
|
|
@@ -65,6 +65,7 @@ blink_modules_sources("webcodecs") {
|
|
"//media/mojo/clients",
|
|
"//media/mojo/mojom",
|
|
"//third_party/libyuv:libyuv",
|
|
+ "//third_party/opus",
|
|
]
|
|
if (media_use_openh264) {
|
|
deps += [ "//third_party/openh264:encoder" ]
|
|
diff --git a/third_party/blink/renderer/modules/webcodecs/DEPS b/third_party/blink/renderer/modules/webcodecs/DEPS
|
|
index b8dd596da8caf..ea1919d12205a 100644
|
|
--- a/third_party/blink/renderer/modules/webcodecs/DEPS
|
|
+++ b/third_party/blink/renderer/modules/webcodecs/DEPS
|
|
@@ -19,6 +19,7 @@ include_rules = [
|
|
|
|
"+third_party/libyuv",
|
|
"+third_party/openh264",
|
|
+ "+third_party/opus",
|
|
|
|
"+ui/gfx/color_space.h",
|
|
"+ui/gfx/geometry/rect.h",
|