PKGBUILDs/alarm/devtools-alarm/0004-arch-nspawn-arm-fix.patch
2015-04-19 16:11:37 +00:00

44 lines
1.3 KiB
Diff

From d07a4e837ad185e1859396231e96edcbdc8b3bd1 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 28 Dec 2014 22:33:00 -0700
Subject: [PATCH 4/6] arch-nspawn: arm fix
---
arch-nspawn.in | 2 +-
makechrootpkg.in | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch-nspawn.in b/arch-nspawn.in
index 20726e8..3f3d563 100644
--- a/arch-nspawn.in
+++ b/arch-nspawn.in
@@ -96,7 +96,7 @@ copy_hostconf
eval $(grep '^CARCH=' "$working_dir/etc/makepkg.conf")
-exec ${CARCH:+setarch "$CARCH"} systemd-nspawn 2>/dev/null \
+exec systemd-nspawn 2>/dev/null \
-D "$working_dir" \
--register=no \
"${mount_args[@]}" \
diff --git a/makechrootpkg.in b/makechrootpkg.in
index 1e73785..ffb14f4 100644
--- a/makechrootpkg.in
+++ b/makechrootpkg.in
@@ -239,10 +239,10 @@ download_sources() {
# Ensure sources are downloaded
if [[ -n $SUDO_USER ]]; then
sudo -u $SUDO_USER env SRCDEST="$SRCDEST" BUILDDIR="$builddir" \
- makepkg --config="$copydir/etc/makepkg.conf" --verifysource -o
+ makepkg -A --config="$copydir/etc/makepkg.conf" --verifysource -o
else
( export SRCDEST BUILDDIR="$builddir"
- makepkg --asroot --config="$copydir/etc/makepkg.conf" --verifysource -o
+ makepkg -A --config="$copydir/etc/makepkg.conf" --verifysource -o
)
fi
(( $? != 0 )) && die "Could not download sources."
--
2.3.2