mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
46 lines
1.8 KiB
Diff
46 lines
1.8 KiB
Diff
diff -Naur bluegriffon-2.1.1.orig/config/content.patch bluegriffon-2.1.1/config/content.patch
|
|
--- bluegriffon-2.1.1.orig/config/content.patch 2016-07-23 21:54:18.367575963 +0000
|
|
+++ bluegriffon-2.1.1/config/content.patch 2016-07-24 00:36:03.891186550 +0000
|
|
@@ -4714,14 +4714,8 @@
|
|
diff --git a/widget/gtk/nsColorPicker.cpp b/widget/gtk/nsColorPicker.cpp
|
|
--- a/widget/gtk/nsColorPicker.cpp
|
|
+++ b/widget/gtk/nsColorPicker.cpp
|
|
-@@ -1,21 +1,24 @@
|
|
- /* -*- Mode: C++; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
|
|
- /* This Source Code Form is subject to the terms of the Mozilla Public
|
|
- * License, v. 2.0. If a copy of the MPL was not distributed with this
|
|
- * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
|
|
-
|
|
+@@ -6,16 +6,18 @@
|
|
#include <gtk/gtk.h>
|
|
-+#include <gtk/gtkcolorsel.h>
|
|
|
|
#include "nsColor.h"
|
|
#include "nsColorPicker.h"
|
|
@@ -4739,7 +4733,7 @@
|
|
return color_component * 255 + 0.5;
|
|
}
|
|
|
|
-@@ -54,38 +57,39 @@ GtkColorSelection* nsColorPicker::Widget
|
|
+@@ -54,38 +56,39 @@ GtkColorSelection* nsColorPicker::Widget
|
|
{
|
|
return GTK_COLOR_SELECTION(gtk_color_selection_dialog_get_color_selection(
|
|
GTK_COLOR_SELECTION_DIALOG(widget)));
|
|
@@ -4785,7 +4779,7 @@
|
|
NS_WARNING("mCallback is already set. Open called twice?");
|
|
return NS_ERROR_FAILURE;
|
|
}
|
|
-@@ -113,16 +117,18 @@ NS_IMETHODIMP nsColorPicker::Open(nsICol
|
|
+@@ -113,16 +116,18 @@ NS_IMETHODIMP nsColorPicker::Open(nsICol
|
|
GtkWidget *color_chooser = gtk_color_selection_dialog_new(title);
|
|
|
|
if (parent_window) {
|
|
@@ -4804,7 +4798,7 @@
|
|
G_CALLBACK(OnColorChanged), this);
|
|
#endif
|
|
|
|
-@@ -176,20 +182,38 @@ nsColorPicker::Update(GtkColorSelection*
|
|
+@@ -176,20 +181,38 @@ nsColorPicker::Update(GtkColorSelection*
|
|
}
|
|
}
|
|
|