mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
68 lines
2.3 KiB
Diff
68 lines
2.3 KiB
Diff
From 4b5d8d0f22ae61ceb45a25391354ba53b43ee992 Mon Sep 17 00:00:00 2001
|
|
From: Michal Schmidt <mschmidt@redhat.com>
|
|
Date: Thu, 6 Nov 2014 22:24:13 +0100
|
|
Subject: [PATCH] shutdown: fix arguments to /run/initramfs/shutdown
|
|
|
|
Our initrd interface specifies that the verb is in argv[1].
|
|
This is where systemd passes it to systemd-shutdown, but getopt
|
|
permutes argv[]. This confuses dracut's shutdown script:
|
|
Shutdown called with argument '--log-level'. Rebooting!
|
|
|
|
getopt can be convinced to not permute argv[] by having '-' as the first
|
|
character of optstring. Let's use it. This requires changing the way
|
|
non-option arguments (in our case, the verb) are processed.
|
|
|
|
This fixes a bug where the system would reboot instead of powering off.
|
|
---
|
|
src/core/shutdown.c | 17 +++++++++++------
|
|
1 file changed, 11 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/src/core/shutdown.c b/src/core/shutdown.c
|
|
index dd11ae3..48ed7fa 100644
|
|
--- a/src/core/shutdown.c
|
|
+++ b/src/core/shutdown.c
|
|
@@ -75,7 +75,9 @@ static int parse_argv(int argc, char *argv[]) {
|
|
assert(argc >= 1);
|
|
assert(argv);
|
|
|
|
- while ((c = getopt_long(argc, argv, "", options, NULL)) >= 0)
|
|
+ /* "-" prevents getopt from permuting argv[] and moving the verb away
|
|
+ * from argv[1]. Our interface to initrd promises it'll be there. */
|
|
+ while ((c = getopt_long(argc, argv, "-", options, NULL)) >= 0)
|
|
switch (c) {
|
|
|
|
case ARG_LOG_LEVEL:
|
|
@@ -113,6 +115,13 @@ static int parse_argv(int argc, char *argv[]) {
|
|
|
|
break;
|
|
|
|
+ case '\001':
|
|
+ if (!arg_verb)
|
|
+ arg_verb = optarg;
|
|
+ else
|
|
+ log_error("Excess arguments, ignoring");
|
|
+ break;
|
|
+
|
|
case '?':
|
|
return -EINVAL;
|
|
|
|
@@ -120,15 +129,11 @@ static int parse_argv(int argc, char *argv[]) {
|
|
assert_not_reached("Unhandled option code.");
|
|
}
|
|
|
|
- if (optind >= argc) {
|
|
+ if (!arg_verb) {
|
|
log_error("Verb argument missing.");
|
|
return -EINVAL;
|
|
}
|
|
|
|
- arg_verb = argv[optind];
|
|
-
|
|
- if (optind + 1 < argc)
|
|
- log_error("Excess arguments, ignoring");
|
|
return 0;
|
|
}
|
|
|
|
--
|
|
2.1.3
|
|
|