PKGBUILDs/extra/ocaml/arm.patch
2014-10-17 03:46:55 +00:00

23 lines
788 B
Diff

diff --git a/asmcomp/CSEgen.ml b/asmcomp/CSEgen.ml
index 19019e1..260e4fa 100644
--- a/asmcomp/CSEgen.ml
+++ b/asmcomp/CSEgen.ml
@@ -180,7 +180,8 @@ method private keep_checkbounds n =
(* Perform CSE on the given instruction [i] and its successors.
[n] is the value numbering current at the beginning of [i]. *)
-method private cse n i =
+method private cse n i = i
+(*
match i.desc with
| Iend | Ireturn | Iop(Itailcall_ind) | Iop(Itailcall_imm _)
| Iexit _ | Iraise _ ->
@@ -262,6 +263,7 @@ method private cse n i =
{i with desc = Itrywith(self#cse n body,
self#cse empty_numbering handler);
next = self#cse empty_numbering i.next}
+*)
method fundecl f =
{f with fun_body = self#cse empty_numbering f.fun_body}