mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
58 lines
2.1 KiB
Diff
58 lines
2.1 KiB
Diff
When calling tp_descr_get(self, obj, type), make sure that we own a reference to "self"
|
|
|
|
diff -ru Python-2.7.9/Objects/typeobject.c Python-2.7.9-fixed//Objects/typeobject.c
|
|
--- Python-2.7.9/Objects/typeobject.c 2014-12-10 16:59:57.000000000 +0100
|
|
+++ Python-2.7.9-fixed//Objects/typeobject.c 2015-11-27 20:39:58.276156800 +0100
|
|
@@ -2542,6 +2542,7 @@
|
|
PyTypeObject *metatype = Py_TYPE(type);
|
|
PyObject *meta_attribute, *attribute;
|
|
descrgetfunc meta_get;
|
|
+ PyObject* res;
|
|
|
|
if (!PyString_Check(name)) {
|
|
PyErr_Format(PyExc_TypeError,
|
|
@@ -2563,6 +2564,7 @@
|
|
meta_attribute = _PyType_Lookup(metatype, name);
|
|
|
|
if (meta_attribute != NULL) {
|
|
+ Py_INCREF(meta_attribute);
|
|
meta_get = Py_TYPE(meta_attribute)->tp_descr_get;
|
|
|
|
if (meta_get != NULL && PyDescr_IsData(meta_attribute)) {
|
|
@@ -2570,10 +2572,11 @@
|
|
* writes. Assume the attribute is not overridden in
|
|
* type's tp_dict (and bases): call the descriptor now.
|
|
*/
|
|
- return meta_get(meta_attribute, (PyObject *)type,
|
|
+ res = meta_get(meta_attribute, (PyObject *)type,
|
|
(PyObject *)metatype);
|
|
+ Py_DECREF(meta_attribute);
|
|
+ return res;
|
|
}
|
|
- Py_INCREF(meta_attribute);
|
|
}
|
|
|
|
/* No data descriptor found on metatype. Look in tp_dict of this
|
|
@@ -2581,6 +2584,7 @@
|
|
attribute = _PyType_Lookup(type, name);
|
|
if (attribute != NULL) {
|
|
/* Implement descriptor functionality, if any */
|
|
+ Py_INCREF(attribute);
|
|
descrgetfunc local_get = Py_TYPE(attribute)->tp_descr_get;
|
|
|
|
Py_XDECREF(meta_attribute);
|
|
@@ -2588,11 +2592,12 @@
|
|
if (local_get != NULL) {
|
|
/* NULL 2nd argument indicates the descriptor was
|
|
* found on the target object itself (or a base) */
|
|
- return local_get(attribute, (PyObject *)NULL,
|
|
+ res = local_get(attribute, (PyObject *)NULL,
|
|
(PyObject *)type);
|
|
+ Py_DECREF(attribute);
|
|
+ return res;
|
|
}
|
|
|
|
- Py_INCREF(attribute);
|
|
return attribute;
|
|
}
|
|
|