mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-29 00:25:25 +00:00
33 lines
1.1 KiB
Diff
33 lines
1.1 KiB
Diff
From 9e8f88c9ae80a2fc984f86f322cd6f2548722789 Mon Sep 17 00:00:00 2001
|
|
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
|
Date: Thu, 21 Nov 2019 21:32:55 +0100
|
|
Subject: [PATCH] Bug 1593167, ensure that loadable certs are loaded when
|
|
TransportSecurityInfo::Read is called
|
|
|
|
Backported to Firefox 70.
|
|
|
|
https://phabricator.services.mozilla.com/D54135
|
|
---
|
|
security/manager/ssl/TransportSecurityInfo.cpp | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
diff --git a/security/manager/ssl/TransportSecurityInfo.cpp b/security/manager/ssl/TransportSecurityInfo.cpp
|
|
index dd3e12a19d41..224ac86ecf1c 100644
|
|
--- a/security/manager/ssl/TransportSecurityInfo.cpp
|
|
+++ b/security/manager/ssl/TransportSecurityInfo.cpp
|
|
@@ -444,6 +444,12 @@ TransportSecurityInfo::Read(nsIObjectInputStream* aStream) {
|
|
return rv;
|
|
}
|
|
|
|
+ // The logic below needs access to loadable certs.
|
|
+ rv = BlockUntilLoadableRootsLoaded();
|
|
+ if (NS_FAILED(rv)) {
|
|
+ return rv;
|
|
+ }
|
|
+
|
|
// moved from nsISSLStatus
|
|
if (!serVersion.EqualsASCII("1")) {
|
|
// nsISSLStatus may be present
|
|
--
|
|
2.24.0
|
|
|