mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
47 lines
1.3 KiB
Diff
47 lines
1.3 KiB
Diff
From 26d0b1d47b76575260a96d1712b1e95cc996ec9c Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Sat, 23 Feb 2019 11:39:31 -0700
|
|
Subject: [PATCH] Remove MMX header
|
|
|
|
---
|
|
Clp/src/ClpPackedMatrix.cpp | 6 ------
|
|
Clp/src/ClpSimplexDual.cpp | 6 ------
|
|
2 files changed, 12 deletions(-)
|
|
|
|
diff --git a/Clp/src/ClpPackedMatrix.cpp b/Clp/src/ClpPackedMatrix.cpp
|
|
index e79bfaa..df2be84 100644
|
|
--- a/Clp/src/ClpPackedMatrix.cpp
|
|
+++ b/Clp/src/ClpPackedMatrix.cpp
|
|
@@ -6747,12 +6747,6 @@ ClpPackedMatrix3::ClpPackedMatrix3()
|
|
, ifActive_(0)
|
|
{
|
|
}
|
|
-#ifdef _MSC_VER
|
|
-#include <intrin.h>
|
|
-#else
|
|
-#include <immintrin.h>
|
|
-//#include <fmaintrin.h>
|
|
-#endif
|
|
/* Constructor from copy. */
|
|
ClpPackedMatrix3::ClpPackedMatrix3(ClpSimplex *model, const CoinPackedMatrix *columnCopy)
|
|
: numberBlocks_(0)
|
|
diff --git a/Clp/src/ClpSimplexDual.cpp b/Clp/src/ClpSimplexDual.cpp
|
|
index a25cd1d..a0a5085 100644
|
|
--- a/Clp/src/ClpSimplexDual.cpp
|
|
+++ b/Clp/src/ClpSimplexDual.cpp
|
|
@@ -3550,12 +3550,6 @@ void moveAndZero(clpTempInfo *info, int type, void *extra)
|
|
}
|
|
}
|
|
#endif
|
|
-#ifdef _MSC_VER
|
|
-#include <intrin.h>
|
|
-#else
|
|
-#include <immintrin.h>
|
|
-//#include <fmaintrin.h>
|
|
-#endif
|
|
int ClpSimplexDual::dualColumn0(const CoinIndexedVector *rowArray,
|
|
const CoinIndexedVector *columnArray,
|
|
CoinIndexedVector *spareArray,
|
|
--
|
|
2.20.1
|
|
|