mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
38 lines
1 KiB
Diff
38 lines
1 KiB
Diff
From 2d8c01f256011c013edf3a76672d6ce9e2b05d8f Mon Sep 17 00:00:00 2001
|
|
From: Eric Anholt <eric@anholt.net>
|
|
Date: Fri, 21 Oct 2016 10:09:47 -0700
|
|
Subject: [PATCH 2/2] Silence runtime complaints on platform devices
|
|
|
|
glxgears was spamming this 12 times at startup because of Mesa's
|
|
probing of the DRM device code, which doesn't support platform
|
|
devices.
|
|
|
|
Signed-off-by: Eric Anholt <eric@anholt.net>
|
|
Reviewed-by: Alex Deucher <alexander.deucher@amd.com>
|
|
---
|
|
xf86drm.c | 2 --
|
|
1 file changed, 2 deletions(-)
|
|
|
|
diff --git a/xf86drm.c b/xf86drm.c
|
|
index 9b52889..52add5e 100644
|
|
--- a/xf86drm.c
|
|
+++ b/xf86drm.c
|
|
@@ -3149,7 +3149,6 @@ int drmGetDevice(int fd, drmDevicePtr *device)
|
|
|
|
break;
|
|
default:
|
|
- fprintf(stderr, "The subsystem type is not supported yet\n");
|
|
continue;
|
|
}
|
|
|
|
@@ -3259,7 +3258,6 @@ int drmGetDevices(drmDevicePtr devices[], int max_devices)
|
|
|
|
break;
|
|
default:
|
|
- fprintf(stderr, "The subsystem type is not supported yet\n");
|
|
continue;
|
|
}
|
|
|
|
--
|
|
2.10.2
|
|
|