mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
39 lines
1.3 KiB
Diff
39 lines
1.3 KiB
Diff
diff --git a/sysdeps/posix/getaddrinfo.c b/sysdeps/posix/getaddrinfo.c
|
|
index 0f4b885..e6ce4cf 100644
|
|
--- a/sysdeps/posix/getaddrinfo.c
|
|
+++ b/sysdeps/posix/getaddrinfo.c
|
|
@@ -1666,13 +1666,13 @@ rfc3484_sort (const void *p1, const void *p2, void *arg)
|
|
|
|
/* Fill in the results in all the records. */
|
|
for (int i = 0; i < src->nresults; ++i)
|
|
- if (src->results[i].index == a1_index)
|
|
+ if (a1_index != -1 && src->results[i].index == a1_index)
|
|
{
|
|
assert (src->results[i].native == -1
|
|
|| src->results[i].native == a1_native);
|
|
src->results[i].native = a1_native;
|
|
}
|
|
- else if (src->results[i].index == a2_index)
|
|
+ else if (a2_index != -1 && src->results[i].index == a2_index)
|
|
{
|
|
assert (src->results[i].native == -1
|
|
|| src->results[i].native == a2_native);
|
|
@@ -2532,7 +2532,14 @@ getaddrinfo (const char *name, const char *service,
|
|
tmp.addr[0] = 0;
|
|
tmp.addr[1] = 0;
|
|
tmp.addr[2] = htonl (0xffff);
|
|
- tmp.addr[3] = sinp->sin_addr.s_addr;
|
|
+ /* Special case for lo interface, the source address
|
|
+ being possibly different than the interface
|
|
+ address. */
|
|
+ if ((ntohl(sinp->sin_addr.s_addr) & 0xff000000)
|
|
+ == 0x7f000000)
|
|
+ tmp.addr[3] = htonl(0x7f000001);
|
|
+ else
|
|
+ tmp.addr[3] = sinp->sin_addr.s_addr;
|
|
}
|
|
else
|
|
{
|
|
--
|
|
1.8.4.1
|
|
|