mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
07430f807d
fixes #1014
29 lines
1.3 KiB
Diff
29 lines
1.3 KiB
Diff
From fa01c108b60f74abb16992c1376bcca896093eac Mon Sep 17 00:00:00 2001
|
|
From: Lars Op den Kamp <lars@opdenkamp.eu>
|
|
Date: Tue, 28 Oct 2014 16:08:00 +0100
|
|
Subject: [PATCH 6/8] [CEC] fixed - don't use CEC_CLIENT_VERSION_CURRENT for
|
|
the client version, because it will lead to issues when XBMC is rebuilt after
|
|
a libCEC bump that changes something
|
|
|
|
---
|
|
xbmc/peripherals/devices/PeripheralCecAdapter.cpp | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/xbmc/peripherals/devices/PeripheralCecAdapter.cpp b/xbmc/peripherals/devices/PeripheralCecAdapter.cpp
|
|
index ad123d9..015daef 100644
|
|
--- a/xbmc/peripherals/devices/PeripheralCecAdapter.cpp
|
|
+++ b/xbmc/peripherals/devices/PeripheralCecAdapter.cpp
|
|
@@ -1268,8 +1268,8 @@ void CPeripheralCecAdapter::SetConfigurationFromLibCEC(const CEC::libcec_configu
|
|
|
|
void CPeripheralCecAdapter::SetConfigurationFromSettings(void)
|
|
{
|
|
- // use the same client version as libCEC version
|
|
- m_configuration.clientVersion = CEC_CLIENT_VERSION_CURRENT;
|
|
+ // client version matches the version of libCEC that we originally used the API from
|
|
+ m_configuration.clientVersion = CEC_CLIENT_VERSION_2_2_0;
|
|
|
|
// device name 'XBMC'
|
|
snprintf(m_configuration.strDeviceName, 13, "%s", GetSettingString("device_name").c_str());
|
|
--
|
|
2.1.2
|
|
|