mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
29 lines
1 KiB
Diff
29 lines
1 KiB
Diff
From b7737c45deaf235db4564d6e004be7be3f9f4836 Mon Sep 17 00:00:00 2001
|
|
From: Fabio Estevam <fabio.estevam@freescale.com>
|
|
Date: Fri, 3 May 2013 04:37:09 +0000
|
|
Subject: [PATCH 05/15] mx23_olinuxino: Fix DDR pin iomux settings
|
|
|
|
Change MUX_CONFIG_EMI to use the same drive strength as the bootlets code from
|
|
Freescale, which results in much better stability.
|
|
|
|
Signed-off-by: Fabio Estevam <fabio.estevam@freescale.com>
|
|
---
|
|
board/olimex/mx23_olinuxino/spl_boot.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/board/olimex/mx23_olinuxino/spl_boot.c b/board/olimex/mx23_olinuxino/spl_boot.c
|
|
index a96c293..3755f29 100644
|
|
--- a/board/olimex/mx23_olinuxino/spl_boot.c
|
|
+++ b/board/olimex/mx23_olinuxino/spl_boot.c
|
|
@@ -29,7 +29,7 @@
|
|
#include <asm/arch/imx-regs.h>
|
|
#include <asm/arch/sys_proto.h>
|
|
|
|
-#define MUX_CONFIG_EMI (MXS_PAD_3V3 | MXS_PAD_16MA | MXS_PAD_PULLUP)
|
|
+#define MUX_CONFIG_EMI (MXS_PAD_3V3 | MXS_PAD_12MA | MXS_PAD_PULLUP)
|
|
#define MUX_CONFIG_SSP (MXS_PAD_3V3 | MXS_PAD_8MA | MXS_PAD_PULLUP)
|
|
|
|
const iomux_cfg_t iomux_setup[] = {
|
|
--
|
|
1.8.2.2
|
|
|