mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
54 lines
2 KiB
Diff
54 lines
2 KiB
Diff
diff -ru lirc-0.9.0/drivers//lirc_atiusb/lirc_atiusb.c lirc-0.9.0.new/drivers//lirc_atiusb/lirc_atiusb.c
|
|
--- lirc-0.9.0/drivers//lirc_atiusb/lirc_atiusb.c 2011-03-25 23:28:18.000000000 +0100
|
|
+++ lirc-0.9.0.new/drivers//lirc_atiusb/lirc_atiusb.c 2011-06-07 17:02:20.356580306 +0200
|
|
@@ -48,7 +48,6 @@
|
|
#include <linux/slab.h>
|
|
#include <linux/module.h>
|
|
#include <linux/kmod.h>
|
|
-#include <linux/smp_lock.h>
|
|
#include <linux/completion.h>
|
|
#include <linux/uaccess.h>
|
|
#include <linux/usb.h>
|
|
diff -ru lirc-0.9.0/drivers//lirc_i2c/lirc_i2c.c lirc-0.9.0.new/drivers//lirc_i2c/lirc_i2c.c
|
|
--- lirc-0.9.0/drivers//lirc_i2c/lirc_i2c.c 2011-03-25 23:28:18.000000000 +0100
|
|
+++ lirc-0.9.0.new/drivers//lirc_i2c/lirc_i2c.c 2011-06-07 17:04:19.725933627 +0200
|
|
@@ -555,8 +555,8 @@
|
|
kfree(ir);
|
|
return -EINVAL;
|
|
}
|
|
- printk(KERN_INFO "lirc_i2c: chip 0x%x found @ 0x%02x (%s)\n",
|
|
- adap->id, addr, ir->c.name);
|
|
+ printk(KERN_INFO "lirc_i2c: chip found @ 0x%02x (%s)\n",
|
|
+ addr, ir->c.name);
|
|
|
|
#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 31)
|
|
/* register device */
|
|
diff -ru lirc-0.9.0/drivers//lirc_wpc8769l/lirc_wpc8769l.c lirc-0.9.0.new/drivers//lirc_wpc8769l/lirc_wpc8769l.c
|
|
--- lirc-0.9.0/drivers//lirc_wpc8769l/lirc_wpc8769l.c 2011-03-25 23:28:18.000000000 +0100
|
|
+++ lirc-0.9.0.new/drivers//lirc_wpc8769l/lirc_wpc8769l.c 2011-06-07 17:07:23.984935411 +0200
|
|
@@ -361,14 +361,14 @@
|
|
size = count << 3;
|
|
|
|
ldata = (unsigned long *) data_buf;
|
|
- next_one = generic_find_next_le_bit(ldata, size, 0);
|
|
+ next_one = find_next_zero_bit_le(ldata, size, 0);
|
|
|
|
if (next_one > 0)
|
|
put_pulse_bit(next_one
|
|
* WPC8769L_USECS_PER_BIT);
|
|
|
|
while (next_one < size) {
|
|
- next_zero = generic_find_next_zero_le_bit(ldata,
|
|
+ next_zero = find_next_zero_bit_le(ldata,
|
|
size, next_one + 1);
|
|
|
|
put_space_bit(
|
|
@@ -376,7 +376,7 @@
|
|
* WPC8769L_USECS_PER_BIT);
|
|
|
|
if (next_zero < size) {
|
|
- next_one = generic_find_next_le_bit(ldata,
|
|
+ next_one = find_next_bit_le(ldata,
|
|
size, next_zero + 1);
|
|
|
|
put_pulse_bit(
|