mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-10-29 22:43:48 +00:00
80 lines
2.1 KiB
Diff
80 lines
2.1 KiB
Diff
From 74bb546b27536c3f9bdd16080a915d98e8c1667f Mon Sep 17 00:00:00 2001
|
|
From: Peter Chen <peter.chen@nxp.com>
|
|
Date: Wed, 21 Jun 2017 14:42:07 +0800
|
|
Subject: [PATCH 13/14] ARM: dts: imx6qdl-udoo.dtsi: fix onboard USB HUB
|
|
property
|
|
|
|
The current dts describes USB HUB's property at USB controller's
|
|
entry, it is improper. The USB HUB should be the child node
|
|
under USB controller, and power sequence properties are under
|
|
it. Besides, using gpio pinctrl setting for USB2415's reset pin.
|
|
|
|
Signed-off-by: Peter Chen <peter.chen@nxp.com>
|
|
Signed-off-by: Joshua Clayton <stillcompiling@gmail.com>
|
|
Tested-by: Maciej S. Szmigiero <mail@maciej.szmigiero.name>
|
|
---
|
|
arch/arm/boot/dts/imx6qdl-udoo.dtsi | 26 ++++++++++++--------------
|
|
1 file changed, 12 insertions(+), 14 deletions(-)
|
|
|
|
diff --git a/arch/arm/boot/dts/imx6qdl-udoo.dtsi b/arch/arm/boot/dts/imx6qdl-udoo.dtsi
|
|
index c96c91d83678..a173de20ee73 100644
|
|
--- a/arch/arm/boot/dts/imx6qdl-udoo.dtsi
|
|
+++ b/arch/arm/boot/dts/imx6qdl-udoo.dtsi
|
|
@@ -9,6 +9,8 @@
|
|
*
|
|
*/
|
|
|
|
+#include <dt-bindings/gpio/gpio.h>
|
|
+
|
|
/ {
|
|
aliases {
|
|
backlight = &backlight;
|
|
@@ -58,17 +60,6 @@
|
|
#address-cells = <1>;
|
|
#size-cells = <0>;
|
|
|
|
- reg_usb_h1_vbus: regulator@0 {
|
|
- compatible = "regulator-fixed";
|
|
- reg = <0>;
|
|
- regulator-name = "usb_h1_vbus";
|
|
- regulator-min-microvolt = <5000000>;
|
|
- regulator-max-microvolt = <5000000>;
|
|
- enable-active-high;
|
|
- startup-delay-us = <2>; /* USB2415 requires a POR of 1 us minimum */
|
|
- gpio = <&gpio7 12 0>;
|
|
- };
|
|
-
|
|
reg_panel: regulator@1 {
|
|
compatible = "regulator-fixed";
|
|
reg = <1>;
|
|
@@ -188,7 +179,7 @@
|
|
|
|
pinctrl_usbh: usbhgrp {
|
|
fsl,pins = <
|
|
- MX6QDL_PAD_GPIO_17__GPIO7_IO12 0x80000000
|
|
+ MX6QDL_PAD_GPIO_17__GPIO7_IO12 0x1b0b0
|
|
MX6QDL_PAD_NANDF_CS2__CCM_CLKO2 0x130b0
|
|
>;
|
|
};
|
|
@@ -259,9 +250,16 @@
|
|
&usbh1 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&pinctrl_usbh>;
|
|
- vbus-supply = <®_usb_h1_vbus>;
|
|
- clocks = <&clks IMX6QDL_CLK_CKO>;
|
|
status = "okay";
|
|
+
|
|
+ usb2415: hub@1 {
|
|
+ compatible = "usb424,2514";
|
|
+ reg = <1>;
|
|
+
|
|
+ clocks = <&clks IMX6QDL_CLK_CKO>;
|
|
+ reset-gpios = <&gpio7 12 GPIO_ACTIVE_LOW>;
|
|
+ reset-duration-us = <3000>;
|
|
+ };
|
|
};
|
|
|
|
&usdhc3 {
|
|
--
|
|
2.16.1
|
|
|