mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
37 lines
1.3 KiB
Diff
37 lines
1.3 KiB
Diff
From d23528cadf4284f508bc4ba05e1b5c14b46bd354 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Ingo=20Kl=C3=B6cker?= <dev@ingo-kloecker.de>
|
|
Date: Mon, 21 Aug 2023 21:08:01 +0200
|
|
Subject: qt,tests: Fix build in source directory
|
|
|
|
* lang/qt/tests/Makefile.am (AM_CPPFLAGS): Include Qt binding sources
|
|
before C++ binding sources and C sources.
|
|
--
|
|
|
|
This fixes the problem that the debug.h in the C sources was found
|
|
before the one in the Qt bindings.
|
|
|
|
GnuPG-bug-id: 6673
|
|
---
|
|
lang/qt/tests/Makefile.am | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/lang/qt/tests/Makefile.am b/lang/qt/tests/Makefile.am
|
|
index 32ad6466..aedd3264 100644
|
|
--- a/lang/qt/tests/Makefile.am
|
|
+++ b/lang/qt/tests/Makefile.am
|
|
@@ -51,10 +51,10 @@ LDADD = ../../cpp/src/libgpgmepp.la ../src/libqgpgme.la \
|
|
../../../src/libgpgme.la @GPGME_QT5_LIBS@ @GPG_ERROR_LIBS@ \
|
|
@GPGME_QT5TEST_LIBS@ @LDADD_FOR_TESTS_KLUDGE@ -lstdc++
|
|
|
|
-AM_CPPFLAGS = -I$(top_srcdir)/lang/cpp/src -I$(top_builddir)/src \
|
|
+AM_CPPFLAGS = -I$(top_srcdir)/lang/qt/src -I$(top_srcdir)/lang/cpp/src \
|
|
+ -I$(top_builddir)/src \
|
|
@GPG_ERROR_CFLAGS@ @GPGME_QT5_CFLAGS@ @GPG_ERROR_CFLAGS@ \
|
|
@LIBASSUAN_CFLAGS@ @GPGME_QT5TEST_CFLAGS@ -DBUILDING_QGPGME \
|
|
- -I$(top_srcdir)/lang/qt/src \
|
|
-DTOP_SRCDIR="$(top_srcdir)"
|
|
endif
|
|
if WANT_QT6
|
|
--
|
|
2.42.0
|
|
|