mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
34 lines
1 KiB
Diff
34 lines
1 KiB
Diff
From 3203606142b15c2f4d3f2a4c55cf9b16d4e92d0c Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Sat, 6 Jul 2019 09:06:56 -0600
|
|
Subject: [PATCH] Fix bcm2835_video_probe with newer firmware
|
|
|
|
https://github.com/raspberrypi/firmware/issues/1157#issuecomment-506706177
|
|
---
|
|
drivers/video/bcm2835.c | 4 +++-
|
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/drivers/video/bcm2835.c b/drivers/video/bcm2835.c
|
|
index bc41090aed..4c7962cad8 100644
|
|
--- a/drivers/video/bcm2835.c
|
|
+++ b/drivers/video/bcm2835.c
|
|
@@ -19,13 +19,15 @@ static int bcm2835_video_probe(struct udevice *dev)
|
|
|
|
debug("bcm2835: Query resolution...\n");
|
|
ret = bcm2835_get_video_size(&w, &h);
|
|
- if (ret)
|
|
+ if (ret || w == 0 || h == 0)
|
|
return -EIO;
|
|
|
|
debug("bcm2835: Setting up display for %d x %d\n", w, h);
|
|
ret = bcm2835_set_video_params(&w, &h, 32, BCM2835_MBOX_PIXEL_ORDER_RGB,
|
|
BCM2835_MBOX_ALPHA_MODE_IGNORED,
|
|
&fb_base, &fb_size, &pitch);
|
|
+ if(ret)
|
|
+ return -EIO;
|
|
|
|
debug("bcm2835: Final resolution is %d x %d\n", w, h);
|
|
|
|
--
|
|
2.21.0
|
|
|