mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
81 lines
3.1 KiB
Diff
81 lines
3.1 KiB
Diff
From 9f5c5d799ed45faff6cb31333b531444d68c2c9a Mon Sep 17 00:00:00 2001
|
|
From: Urs Fleisch <ufleisch@users.sourceforge.net>
|
|
Date: Fri, 26 Feb 2016 17:46:09 +0100
|
|
Subject: [PATCH] xcb: Fix drag and drop to applications like Emacs and
|
|
Chromium.
|
|
|
|
Drops without matching time stamp do not work. I have fixed the issue by
|
|
reanimating the findXdndAwareParent() function (adapted to XCB) and
|
|
using it to find a matching transaction if all else fails.
|
|
|
|
Task-number: QTBUG-45812
|
|
Change-Id: Ibca15bbab02ccf2f25280418e9edf36972ebf9a0
|
|
---
|
|
src/plugins/platforms/xcb/qxcbdrag.cpp | 44 ++++++++++++++++++++++++++++++++++
|
|
1 file changed, 44 insertions(+)
|
|
|
|
diff --git a/src/plugins/platforms/xcb/qxcbdrag.cpp b/src/plugins/platforms/xcb/qxcbdrag.cpp
|
|
index 1d13adf..b22f4af 100644
|
|
--- a/src/plugins/platforms/xcb/qxcbdrag.cpp
|
|
+++ b/src/plugins/platforms/xcb/qxcbdrag.cpp
|
|
@@ -1074,6 +1074,40 @@ void QXcbDrag::cancel()
|
|
send_leave();
|
|
}
|
|
|
|
+// find an ancestor with XdndAware on it
|
|
+static xcb_window_t findXdndAwareParent(QXcbConnection *c, xcb_window_t window)
|
|
+{
|
|
+ xcb_window_t target = 0;
|
|
+ forever {
|
|
+ // check if window has XdndAware
|
|
+ xcb_get_property_cookie_t gpCookie = Q_XCB_CALL(
|
|
+ xcb_get_property(c->xcb_connection(), false, window,
|
|
+ c->atom(QXcbAtom::XdndAware), XCB_GET_PROPERTY_TYPE_ANY, 0, 0));
|
|
+ xcb_get_property_reply_t *gpReply = xcb_get_property_reply(
|
|
+ c->xcb_connection(), gpCookie, 0);
|
|
+ bool aware = gpReply && gpReply->type != XCB_NONE;
|
|
+ free(gpReply);
|
|
+ if (aware) {
|
|
+ target = window;
|
|
+ break;
|
|
+ }
|
|
+
|
|
+ // try window's parent
|
|
+ xcb_query_tree_cookie_t qtCookie = xcb_query_tree_unchecked(
|
|
+ c->xcb_connection(), window);
|
|
+ xcb_query_tree_reply_t *qtReply = xcb_query_tree_reply(
|
|
+ c->xcb_connection(), qtCookie, NULL);
|
|
+ if (!qtReply)
|
|
+ break;
|
|
+ xcb_window_t root = qtReply->root;
|
|
+ xcb_window_t parent = qtReply->parent;
|
|
+ free(qtReply);
|
|
+ if (window == root)
|
|
+ break;
|
|
+ window = parent;
|
|
+ }
|
|
+ return target;
|
|
+}
|
|
|
|
void QXcbDrag::handleSelectionRequest(const xcb_selection_request_event_t *event)
|
|
{
|
|
@@ -1101,6 +1135,16 @@ void QXcbDrag::handleSelectionRequest(const xcb_selection_request_event_t *event
|
|
// xcb_convert_selection() that we sent the XdndDrop event to.
|
|
at = findTransactionByWindow(event->requestor);
|
|
}
|
|
+
|
|
+ if (at == -1 && event->time == XCB_CURRENT_TIME) {
|
|
+ xcb_window_t target = findXdndAwareParent(connection(), event->requestor);
|
|
+ if (target) {
|
|
+ if (current_target && current_target == target)
|
|
+ at = -2;
|
|
+ else
|
|
+ at = findTransactionByWindow(target);
|
|
+ }
|
|
+ }
|
|
// if (at == -1 && event->time == XCB_CURRENT_TIME) {
|
|
// // previous Qt versions always requested the data on a child of the target window
|
|
// // using CurrentTime... but it could be asking for either drop data or the current drag's data
|
|
--
|
|
2.7.4
|
|
|