PKGBUILDs/core/systemd/0001-fsck-disable-l-option-for-now.patch
2014-06-14 00:16:28 +00:00

59 lines
1.8 KiB
Diff

From c343be283b7152554bac0c02493a4e1759c163f7 Mon Sep 17 00:00:00 2001
From: Kay Sievers <kay@vrfy.org>
Date: Wed, 4 Jun 2014 11:14:48 +0200
Subject: [PATCH] fsck: disable "-l" option for now
https://bugs.freedesktop.org/show_bug.cgi?id=79576#c5
---
TODO | 4 +++-
src/fsck/fsck.c | 13 ++++++++++++-
2 files changed, 15 insertions(+), 2 deletions(-)
diff --git a/TODO b/TODO
index 8169a57..fb118f1 100644
--- a/TODO
+++ b/TODO
@@ -1,4 +1,7 @@
Bugfixes:
+* Re-enable "fsck -l" when it is ready:
+ https://bugs.freedesktop.org/show_bug.cgi?id=79576#c5
+
* Should systemctl status \* work on all unit types, not just .service?
* enabling an instance unit creates a pointless link, and
@@ -20,7 +23,6 @@ Bugfixes:
See the comment in sd_bus_unref() for more..
External:
-
* Fedora: when installing fedora with yum --installroot /var/run is a directory, not a symlink
https://bugzilla.redhat.com/show_bug.cgi?id=975864
diff --git a/src/fsck/fsck.c b/src/fsck/fsck.c
index 56cb52d..cb2f573 100644
--- a/src/fsck/fsck.c
+++ b/src/fsck/fsck.c
@@ -319,7 +319,18 @@ int main(int argc, char *argv[]) {
cmdline[i++] = "/sbin/fsck";
cmdline[i++] = arg_repair;
cmdline[i++] = "-T";
- cmdline[i++] = "-l";
+
+ /*
+ * Disable locking which conflict with udev's event
+ * ownershipi, until util-linux moves the flock
+ * synchronization file which prevents multiple fsck running
+ * on the same rotationg media, from the disk device
+ * node to a privately owned regular file.
+ *
+ * https://bugs.freedesktop.org/show_bug.cgi?id=79576#c5
+ *
+ * cmdline[i++] = "-l";
+ */
if (!root_directory)
cmdline[i++] = "-M";
--
2.0.0