mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
38 lines
1.4 KiB
Diff
38 lines
1.4 KiB
Diff
From c6ffa8bb3eea231c36dab87e6051c04b16e8c0e6 Mon Sep 17 00:00:00 2001
|
|
Message-Id: <c6ffa8bb3eea231c36dab87e6051c04b16e8c0e6.1524246116.git.jan.steffens@gmail.com>
|
|
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
|
Date: Fri, 20 Apr 2018 19:25:55 +0200
|
|
Subject: [PATCH] libmakepkg: Support file 5.33's application/x-pie-executable
|
|
|
|
file 5.33 introduces a new MIME type "application/x-pie-executable",
|
|
which is used for relocatable binaries. makepkg ignored these binaries
|
|
and did not attempt to strip them.
|
|
|
|
Handle the new MIME type like the old "application/x-sharedlib".
|
|
Stripping the binaries with --strip-unneeded to keep relocation
|
|
information should be the correct thing to do.
|
|
|
|
file 5.33 also misidentifies actual libraries as PIE executables, so we
|
|
didn't strip any shared libraries, either. We now work around this bug.
|
|
|
|
Signed-off-by: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
|
---
|
|
scripts/libmakepkg/tidy/strip.sh.in | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/scripts/libmakepkg/tidy/strip.sh.in b/scripts/libmakepkg/tidy/strip.sh.in
|
|
index e20114c0..36d1b89e 100644
|
|
--- a/scripts/libmakepkg/tidy/strip.sh.in
|
|
+++ b/scripts/libmakepkg/tidy/strip.sh.in
|
|
@@ -125,6 +125,8 @@ tidy_strip() {
|
|
esac;;
|
|
*application/x-executable*) # Binaries
|
|
strip_flags="$STRIP_BINARIES";;
|
|
+ *application/x-pie-executable*) # Relocatable binaries
|
|
+ strip_flags="$STRIP_SHARED";;
|
|
*)
|
|
continue ;;
|
|
esac
|
|
--
|
|
2.17.0
|
|
|