PKGBUILDs/extra/python/test_gdb-version-fix.patch
2015-10-01 23:42:14 +00:00

12 lines
607 B
Diff

--- a/Lib/test/test_gdb.py 2015-09-14 11:58:09.218811556 +0800
+++ b/Lib/test/test_gdb.py 2015-09-14 11:58:24.845647558 +0800
@@ -28,7 +28,7 @@
# This is what "no gdb" looks like. There may, however, be other
# errors that manifest this way too.
raise unittest.SkipTest("Couldn't find gdb on the path")
-gdb_version_number = re.search(b"^GNU gdb [^\d]*(\d+)\.(\d)", gdb_version)
+gdb_version_number = re.search(b"^GNU gdb [^\d]*(\d+)\.(\d+)", gdb_version)
gdb_major_version = int(gdb_version_number.group(1))
gdb_minor_version = int(gdb_version_number.group(2))
if gdb_major_version < 7: