mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
50 lines
1.3 KiB
Diff
50 lines
1.3 KiB
Diff
diff --git a/bfd/elf.c b/bfd/elf.c
|
|
index 3fcf2d8..949221f 100644
|
|
--- a/bfd/elf.c
|
|
+++ b/bfd/elf.c
|
|
@@ -629,7 +629,7 @@ setup_group (bfd *abfd, Elf_Internal_Shdr *hdr, asection *newsect)
|
|
memset (shdr->contents, 0, amt);
|
|
continue;
|
|
}
|
|
-
|
|
+
|
|
/* Translate raw contents, a flag word followed by an
|
|
array of elf section indices all in target byte order,
|
|
to the flag word followed by an array of elf section
|
|
diff --git a/bfd/peXXigen.c b/bfd/peXXigen.c
|
|
index c7d6067..6129085 100644
|
|
--- a/bfd/peXXigen.c
|
|
+++ b/bfd/peXXigen.c
|
|
@@ -515,7 +515,6 @@ _bfd_XXi_swap_aouthdr_in (bfd * abfd,
|
|
a->NumberOfRvaAndSizes = 0;
|
|
}
|
|
|
|
-
|
|
for (idx = 0; idx < a->NumberOfRvaAndSizes; idx++)
|
|
{
|
|
/* If data directory is empty, rva also should be 0. */
|
|
diff --git a/bfd/srec.c b/bfd/srec.c
|
|
index 9ed2080..5f9a546 100644
|
|
--- a/bfd/srec.c
|
|
+++ b/bfd/srec.c
|
|
@@ -246,7 +246,7 @@ srec_bad_byte (bfd *abfd,
|
|
}
|
|
else
|
|
{
|
|
- char buf[10];
|
|
+ char buf[40];
|
|
|
|
if (! ISPRINT (c))
|
|
sprintf (buf, "\\%03o", (unsigned int) c);
|
|
@@ -452,7 +452,7 @@ srec_scan (bfd *abfd)
|
|
case 'S':
|
|
{
|
|
file_ptr pos;
|
|
- char hdr[3];
|
|
+ unsigned char hdr[3];
|
|
unsigned int bytes, min_bytes;
|
|
bfd_vma address;
|
|
bfd_byte *data;
|
|
--
|
|
1.7.1
|
|
|