mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
34 lines
1.4 KiB
Diff
34 lines
1.4 KiB
Diff
From 083c9269ed73e8771e1dbe10812696b45b7389f3 Mon Sep 17 00:00:00 2001
|
|
From: Evangelos Foutras <evangelos@foutrelis.com>
|
|
Date: Mon, 11 May 2015 12:20:57 +0300
|
|
Subject: [PATCH] Try to ensure that -fPIC is used in CMake builds
|
|
|
|
In commit 36d6eb721e7d5997ade75e289d4088dc48678d0d the -fPIE switch was
|
|
replaced with -fPIC in an effort to avoid generating copy relocations
|
|
which are incompatible with Qt5 when built with -reduce-relocations.
|
|
|
|
Task-number: QTBUG-45755
|
|
Change-Id: I59a55ea15052f498104848c5fd867e563ddc2290
|
|
Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
|
|
---
|
|
src/corelib/Qt5CoreConfigExtras.cmake.in | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/src/corelib/Qt5CoreConfigExtras.cmake.in b/src/corelib/Qt5CoreConfigExtras.cmake.in
|
|
index 48d5f21..d4abc5f 100644
|
|
--- a/src/corelib/Qt5CoreConfigExtras.cmake.in
|
|
+++ b/src/corelib/Qt5CoreConfigExtras.cmake.in
|
|
@@ -70,8 +70,9 @@ set(_qt5_corelib_extra_includes)
|
|
# Qt5_POSITION_INDEPENDENT_CODE variable is used in the # qt5_use_module
|
|
# macro to add it.
|
|
set(Qt5_POSITION_INDEPENDENT_CODE True)
|
|
-set_property(TARGET Qt5::Core PROPERTY INTERFACE_POSITION_INDEPENDENT_CODE \"ON\")
|
|
set(Qt5Core_EXECUTABLE_COMPILE_FLAGS \"-fPIC\")
|
|
+set_property(TARGET Qt5::Core PROPERTY INTERFACE_POSITION_INDEPENDENT_CODE \"ON\")
|
|
+set_property(TARGET Qt5::Core APPEND PROPERTY INTERFACE_COMPILE_OPTIONS ${Qt5Core_EXECUTABLE_COMPILE_FLAGS})
|
|
!!ENDIF
|
|
|
|
!!IF !isEmpty(QT_NAMESPACE)
|
|
--
|
|
2.4.0
|
|
|