PKGBUILDs/core/mkinitcpio/0001-use-gzip-for-compression-by-default.patch
2023-03-26 22:27:16 +00:00

54 lines
2 KiB
Diff

From 19178cb8b2874f83fbd8b3659a2d1d532af881a3 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 20 Feb 2021 10:02:34 -0700
Subject: [PATCH 1/3] use gzip for compression by default
---
man/mkinitcpio.conf.5.adoc | 2 +-
mkinitcpio | 2 +-
mkinitcpio.conf | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/man/mkinitcpio.conf.5.adoc b/man/mkinitcpio.conf.5.adoc
index 08b95c5..41c29be 100644
--- a/man/mkinitcpio.conf.5.adoc
+++ b/man/mkinitcpio.conf.5.adoc
@@ -56,7 +56,7 @@ Variables
Defines a program to filter the generated image through. The kernel
understands the compression formats yielded by the *zstd*, *gzip*, *bzip2*,
*lz4*, *lzop*, *lzma*, and *xz* compressors. If unspecified, this setting
- defaults to *zstd* compression. In order to create an uncompressed image,
+ defaults to *gzip* compression. In order to create an uncompressed image,
define this variable as *cat*.
+
It's not hard to realize that a filter such as a *tac* or *rev* will cause
diff --git a/mkinitcpio b/mkinitcpio
index 0c6dc60..f68d70c 100755
--- a/mkinitcpio
+++ b/mkinitcpio
@@ -856,7 +856,7 @@ if [[ -n "$_optgenimg" ]]; then
die "Unable to write to '%s'" "$_optgenimg"
fi
- _optcompress="${_optcompress:-"${COMPRESSION:-zstd}"}"
+ _optcompress="${_optcompress:-"${COMPRESSION:-gzip}"}"
if ! type -P "$_optcompress" >/dev/null; then
warning "Unable to locate compression method: '%s'" "$_optcompress"
_optcompress='cat'
diff --git a/mkinitcpio.conf b/mkinitcpio.conf
index 710e05f..4a2ce87 100644
--- a/mkinitcpio.conf
+++ b/mkinitcpio.conf
@@ -52,7 +52,7 @@ FILES=()
HOOKS=(base udev autodetect modconf kms keyboard keymap consolefont block filesystems fsck)
# COMPRESSION
-# Use this to compress the initramfs image. By default, zstd compression
+# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="zstd"
#COMPRESSION="gzip"
--
2.36.1