PKGBUILDs/community/libvirt/0009-Revert-build-require-Jansson-if-QEMU-driver-is-enabl.patch
2018-08-18 17:04:26 +00:00

40 lines
1.2 KiB
Diff

From a1bd0be0213fdeb8e8f34912ca346add5583db36 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?J=C3=A1n=20Tomko?= <jtomko@redhat.com>
Date: Mon, 13 Aug 2018 13:39:39 +0200
Subject: [PATCH 09/16] Revert "build: require Jansson if QEMU driver is
enabled"
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
This reverts commit 01ce04375c3348fd683475e5aa5231149ef6a78a.
Jansson cannot parse QEMU's quirky JSON.
Revert back to yajl.
https://bugzilla.redhat.com/show_bug.cgi?id=1614569
Signed-off-by: Ján Tomko <jtomko@redhat.com>
Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
---
m4/virt-driver-qemu.m4 | 3 ---
1 file changed, 3 deletions(-)
diff --git a/m4/virt-driver-qemu.m4 b/m4/virt-driver-qemu.m4
index 2d9992d0dc..ddb2834705 100644
--- a/m4/virt-driver-qemu.m4
+++ b/m4/virt-driver-qemu.m4
@@ -27,9 +27,6 @@ AC_DEFUN([LIBVIRT_DRIVER_ARG_QEMU], [
AC_DEFUN([LIBVIRT_DRIVER_CHECK_QEMU], [
AC_REQUIRE([LIBVIRT_CHECK_JANSSON])
- if test "$with_qemu:$with_jansson" = "yes:no"; then
- AC_MSG_ERROR([Jansson >= 2.5 is required to build QEMU driver])
- fi
if test "$with_qemu" = "check"; then
with_qemu=$with_jansson
fi
--
2.18.0