mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
18 lines
585 B
Diff
18 lines
585 B
Diff
--- a/pyuno/source/module/uno.py 2017-05-03 18:46:29.000000000 +0200
|
|
+++ b/pyuno/source/module/uno.py.new 2017-06-06 17:11:27.585959637 +0200
|
|
@@ -16,8 +16,14 @@
|
|
# except in compliance with the License. You may obtain a copy of
|
|
# the License at http://www.apache.org/licenses/LICENSE-2.0 .
|
|
#
|
|
-import pyuno
|
|
+
|
|
+# Special modification to make uno load on Arch
|
|
+import os
|
|
import sys
|
|
+sys.path.append("/usr/lib/libreoffice/program/")
|
|
+os.putenv("URE_BOOTSTRAP", "vnd.sun.star.pathname:/usr/lib/libreoffice/program/fundamentalrc")
|
|
+
|
|
+import pyuno
|
|
import traceback
|
|
import warnings
|
|
|