mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
258 lines
12 KiB
Diff
258 lines
12 KiB
Diff
From 6a0b7c8ecf0734ba1bcdccf8e0ee97e721fd5420 Mon Sep 17 00:00:00 2001
|
|
Message-Id: <6a0b7c8ecf0734ba1bcdccf8e0ee97e721fd5420.1505113337.git.jan.steffens@gmail.com>
|
|
From: =?UTF-8?q?Emilio=20Cobos=20=C3=81lvarez?= <emilio@crisal.io>
|
|
Date: Sat, 19 Aug 2017 20:14:25 +0200
|
|
Subject: [PATCH] Fix use of struct ucontext (squash 2 commits)
|
|
|
|
Needed for building with glibc 2.26.
|
|
|
|
Bug 1385667: Use ucontext_t consistently in breakpad-client. r=ted
|
|
MozReview-Commit-ID: AJhzJdNXP0f
|
|
|
|
Bug 1394149: Fix remaining uses of ucontext in breakpad-client. r=ted
|
|
MozReview-Commit-ID: 5tP7fXsI7dQ
|
|
---
|
|
.../linux/dump_writer_common/ucontext_reader.cc | 30 +++++++++++-----------
|
|
.../linux/dump_writer_common/ucontext_reader.h | 10 ++++----
|
|
.../linux/handler/exception_handler.cc | 10 ++++----
|
|
.../linux/handler/exception_handler.h | 2 +-
|
|
.../linux/microdump_writer/microdump_writer.cc | 2 +-
|
|
.../linux/minidump_writer/minidump_writer.cc | 2 +-
|
|
6 files changed, 28 insertions(+), 28 deletions(-)
|
|
|
|
diff --git a/toolkit/crashreporter/breakpad-client/linux/dump_writer_common/ucontext_reader.cc b/toolkit/crashreporter/breakpad-client/linux/dump_writer_common/ucontext_reader.cc
|
|
index 999960912e459e1b..303c0ebd32b663c4 100644
|
|
--- a/toolkit/crashreporter/breakpad-client/linux/dump_writer_common/ucontext_reader.cc
|
|
+++ b/toolkit/crashreporter/breakpad-client/linux/dump_writer_common/ucontext_reader.cc
|
|
@@ -40,15 +40,15 @@ namespace google_breakpad {
|
|
|
|
#if defined(__i386__)
|
|
|
|
-uintptr_t UContextReader::GetStackPointer(const struct ucontext* uc) {
|
|
+uintptr_t UContextReader::GetStackPointer(const ucontext_t* uc) {
|
|
return uc->uc_mcontext.gregs[REG_ESP];
|
|
}
|
|
|
|
-uintptr_t UContextReader::GetInstructionPointer(const struct ucontext* uc) {
|
|
+uintptr_t UContextReader::GetInstructionPointer(const ucontext_t* uc) {
|
|
return uc->uc_mcontext.gregs[REG_EIP];
|
|
}
|
|
|
|
-void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc,
|
|
+void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext_t *uc,
|
|
const struct _libc_fpstate* fp) {
|
|
const greg_t* regs = uc->uc_mcontext.gregs;
|
|
|
|
@@ -88,15 +88,15 @@ void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc,
|
|
|
|
#elif defined(__x86_64)
|
|
|
|
-uintptr_t UContextReader::GetStackPointer(const struct ucontext* uc) {
|
|
+uintptr_t UContextReader::GetStackPointer(const ucontext_t* uc) {
|
|
return uc->uc_mcontext.gregs[REG_RSP];
|
|
}
|
|
|
|
-uintptr_t UContextReader::GetInstructionPointer(const struct ucontext* uc) {
|
|
+uintptr_t UContextReader::GetInstructionPointer(const ucontext_t* uc) {
|
|
return uc->uc_mcontext.gregs[REG_RIP];
|
|
}
|
|
|
|
-void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc,
|
|
+void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext_t *uc,
|
|
const struct _libc_fpstate* fpregs) {
|
|
const greg_t* regs = uc->uc_mcontext.gregs;
|
|
|
|
@@ -145,15 +145,15 @@ void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc,
|
|
|
|
#elif defined(__ARM_EABI__)
|
|
|
|
-uintptr_t UContextReader::GetStackPointer(const struct ucontext* uc) {
|
|
+uintptr_t UContextReader::GetStackPointer(const ucontext_t* uc) {
|
|
return uc->uc_mcontext.arm_sp;
|
|
}
|
|
|
|
-uintptr_t UContextReader::GetInstructionPointer(const struct ucontext* uc) {
|
|
+uintptr_t UContextReader::GetInstructionPointer(const ucontext_t* uc) {
|
|
return uc->uc_mcontext.arm_pc;
|
|
}
|
|
|
|
-void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc) {
|
|
+void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext_t *uc) {
|
|
out->context_flags = MD_CONTEXT_ARM_FULL;
|
|
|
|
out->iregs[0] = uc->uc_mcontext.arm_r0;
|
|
@@ -184,41 +184,41 @@ void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc) {
|
|
|
|
#elif defined(__aarch64__)
|
|
|
|
-uintptr_t UContextReader::GetStackPointer(const struct ucontext* uc) {
|
|
+uintptr_t UContextReader::GetStackPointer(const ucontext_t* uc) {
|
|
return uc->uc_mcontext.sp;
|
|
}
|
|
|
|
-uintptr_t UContextReader::GetInstructionPointer(const struct ucontext* uc) {
|
|
+uintptr_t UContextReader::GetInstructionPointer(const ucontext_t* uc) {
|
|
return uc->uc_mcontext.pc;
|
|
}
|
|
|
|
-void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc,
|
|
+void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext_t *uc,
|
|
const struct fpsimd_context* fpregs) {
|
|
out->context_flags = MD_CONTEXT_ARM64_FULL;
|
|
|
|
out->cpsr = static_cast<uint32_t>(uc->uc_mcontext.pstate);
|
|
for (int i = 0; i < MD_CONTEXT_ARM64_REG_SP; ++i)
|
|
out->iregs[i] = uc->uc_mcontext.regs[i];
|
|
out->iregs[MD_CONTEXT_ARM64_REG_SP] = uc->uc_mcontext.sp;
|
|
out->iregs[MD_CONTEXT_ARM64_REG_PC] = uc->uc_mcontext.pc;
|
|
|
|
out->float_save.fpsr = fpregs->fpsr;
|
|
out->float_save.fpcr = fpregs->fpcr;
|
|
my_memcpy(&out->float_save.regs, &fpregs->vregs,
|
|
MD_FLOATINGSAVEAREA_ARM64_FPR_COUNT * 16);
|
|
}
|
|
|
|
#elif defined(__mips__)
|
|
|
|
-uintptr_t UContextReader::GetStackPointer(const struct ucontext* uc) {
|
|
+uintptr_t UContextReader::GetStackPointer(const ucontext_t* uc) {
|
|
return uc->uc_mcontext.gregs[MD_CONTEXT_MIPS_REG_SP];
|
|
}
|
|
|
|
-uintptr_t UContextReader::GetInstructionPointer(const struct ucontext* uc) {
|
|
+uintptr_t UContextReader::GetInstructionPointer(const ucontext_t* uc) {
|
|
return uc->uc_mcontext.pc;
|
|
}
|
|
|
|
-void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc) {
|
|
+void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext_t *uc) {
|
|
#if _MIPS_SIM == _ABI64
|
|
out->context_flags = MD_CONTEXT_MIPS64_FULL;
|
|
#elif _MIPS_SIM == _ABIO32
|
|
diff --git a/toolkit/crashreporter/breakpad-client/linux/dump_writer_common/ucontext_reader.h b/toolkit/crashreporter/breakpad-client/linux/dump_writer_common/ucontext_reader.h
|
|
index c533e28ba7441e83..039752a2dfb6e589 100644
|
|
--- a/toolkit/crashreporter/breakpad-client/linux/dump_writer_common/ucontext_reader.h
|
|
+++ b/toolkit/crashreporter/breakpad-client/linux/dump_writer_common/ucontext_reader.h
|
|
@@ -41,21 +41,21 @@ namespace google_breakpad {
|
|
|
|
// Wraps platform-dependent implementations of accessors to ucontext structs.
|
|
struct UContextReader {
|
|
- static uintptr_t GetStackPointer(const struct ucontext* uc);
|
|
+ static uintptr_t GetStackPointer(const ucontext_t* uc);
|
|
|
|
- static uintptr_t GetInstructionPointer(const struct ucontext* uc);
|
|
+ static uintptr_t GetInstructionPointer(const ucontext_t* uc);
|
|
|
|
// Juggle a arch-specific ucontext into a minidump format
|
|
// out: the minidump structure
|
|
// info: the collection of register structures.
|
|
#if defined(__i386__) || defined(__x86_64)
|
|
- static void FillCPUContext(RawContextCPU *out, const ucontext *uc,
|
|
+ static void FillCPUContext(RawContextCPU *out, const ucontext_t *uc,
|
|
const struct _libc_fpstate* fp);
|
|
#elif defined(__aarch64__)
|
|
- static void FillCPUContext(RawContextCPU *out, const ucontext *uc,
|
|
+ static void FillCPUContext(RawContextCPU *out, const ucontext_t *uc,
|
|
const struct fpsimd_context* fpregs);
|
|
#else
|
|
- static void FillCPUContext(RawContextCPU *out, const ucontext *uc);
|
|
+ static void FillCPUContext(RawContextCPU *out, const ucontext_t *uc);
|
|
#endif
|
|
};
|
|
|
|
diff --git a/toolkit/crashreporter/breakpad-client/linux/handler/exception_handler.cc b/toolkit/crashreporter/breakpad-client/linux/handler/exception_handler.cc
|
|
index 71a51a763938e39d..12df9bc96ec45fea 100644
|
|
--- a/toolkit/crashreporter/breakpad-client/linux/handler/exception_handler.cc
|
|
+++ b/toolkit/crashreporter/breakpad-client/linux/handler/exception_handler.cc
|
|
@@ -439,44 +439,44 @@ bool ExceptionHandler::HandleSignal(int sig, siginfo_t* info, void* uc) {
|
|
// Fill in all the holes in the struct to make Valgrind happy.
|
|
memset(&g_crash_context_, 0, sizeof(g_crash_context_));
|
|
memcpy(&g_crash_context_.siginfo, info, sizeof(siginfo_t));
|
|
- memcpy(&g_crash_context_.context, uc, sizeof(struct ucontext));
|
|
+ memcpy(&g_crash_context_.context, uc, sizeof(ucontext_t));
|
|
#if defined(__aarch64__)
|
|
- struct ucontext* uc_ptr = (struct ucontext*)uc;
|
|
+ ucontext_t* uc_ptr = (ucontext_t*)uc;
|
|
struct fpsimd_context* fp_ptr =
|
|
(struct fpsimd_context*)&uc_ptr->uc_mcontext.__reserved;
|
|
if (fp_ptr->head.magic == FPSIMD_MAGIC) {
|
|
memcpy(&g_crash_context_.float_state, fp_ptr,
|
|
sizeof(g_crash_context_.float_state));
|
|
}
|
|
#elif !defined(__ARM_EABI__) && !defined(__mips__)
|
|
// FP state is not part of user ABI on ARM Linux.
|
|
- // In case of MIPS Linux FP state is already part of struct ucontext
|
|
+ // In case of MIPS Linux FP state is already part of ucontext_t
|
|
// and 'float_state' is not a member of CrashContext.
|
|
- struct ucontext* uc_ptr = (struct ucontext*)uc;
|
|
+ ucontext_t* uc_ptr = (ucontext_t*)uc;
|
|
if (uc_ptr->uc_mcontext.fpregs) {
|
|
memcpy(&g_crash_context_.float_state, uc_ptr->uc_mcontext.fpregs,
|
|
sizeof(g_crash_context_.float_state));
|
|
}
|
|
#endif
|
|
g_crash_context_.tid = syscall(__NR_gettid);
|
|
if (crash_handler_ != NULL) {
|
|
if (crash_handler_(&g_crash_context_, sizeof(g_crash_context_),
|
|
callback_context_)) {
|
|
return true;
|
|
}
|
|
}
|
|
return GenerateDump(&g_crash_context_);
|
|
}
|
|
|
|
// This is a public interface to HandleSignal that allows the client to
|
|
// generate a crash dump. This function may run in a compromised context.
|
|
bool ExceptionHandler::SimulateSignalDelivery(int sig) {
|
|
siginfo_t siginfo = {};
|
|
// Mimic a trusted signal to allow tracing the process (see
|
|
// ExceptionHandler::HandleSignal().
|
|
siginfo.si_code = SI_USER;
|
|
siginfo.si_pid = getpid();
|
|
- struct ucontext context;
|
|
+ ucontext_t context;
|
|
getcontext(&context);
|
|
return HandleSignal(sig, &siginfo, &context);
|
|
}
|
|
diff --git a/toolkit/crashreporter/breakpad-client/linux/handler/exception_handler.h b/toolkit/crashreporter/breakpad-client/linux/handler/exception_handler.h
|
|
index 711586fec7ddae59..be1880170e2826b0 100644
|
|
--- a/toolkit/crashreporter/breakpad-client/linux/handler/exception_handler.h
|
|
+++ b/toolkit/crashreporter/breakpad-client/linux/handler/exception_handler.h
|
|
@@ -191,7 +191,7 @@ class ExceptionHandler {
|
|
struct CrashContext {
|
|
siginfo_t siginfo;
|
|
pid_t tid; // the crashing thread.
|
|
- struct ucontext context;
|
|
+ ucontext_t context;
|
|
#if !defined(__ARM_EABI__) && !defined(__mips__)
|
|
// #ifdef this out because FP state is not part of user ABI for Linux ARM.
|
|
// In case of MIPS Linux FP state is already part of struct
|
|
diff --git a/toolkit/crashreporter/breakpad-client/linux/microdump_writer/microdump_writer.cc b/toolkit/crashreporter/breakpad-client/linux/microdump_writer/microdump_writer.cc
|
|
index ff20bf36584c876b..a0b90e08fc5f0cff 100644
|
|
--- a/toolkit/crashreporter/breakpad-client/linux/microdump_writer/microdump_writer.cc
|
|
+++ b/toolkit/crashreporter/breakpad-client/linux/microdump_writer/microdump_writer.cc
|
|
@@ -571,7 +571,7 @@ class MicrodumpWriter {
|
|
|
|
void* Alloc(unsigned bytes) { return dumper_->allocator()->Alloc(bytes); }
|
|
|
|
- const struct ucontext* const ucontext_;
|
|
+ const ucontext_t* const ucontext_;
|
|
#if !defined(__ARM_EABI__) && !defined(__mips__)
|
|
const google_breakpad::fpstate_t* const float_state_;
|
|
#endif
|
|
diff --git a/toolkit/crashreporter/breakpad-client/linux/minidump_writer/minidump_writer.cc b/toolkit/crashreporter/breakpad-client/linux/minidump_writer/minidump_writer.cc
|
|
index 0650bb95c179464a..6b5304bcd605ca3a 100644
|
|
--- a/toolkit/crashreporter/breakpad-client/linux/minidump_writer/minidump_writer.cc
|
|
+++ b/toolkit/crashreporter/breakpad-client/linux/minidump_writer/minidump_writer.cc
|
|
@@ -1247,7 +1247,7 @@ class MinidumpWriter {
|
|
const int fd_; // File descriptor where the minidum should be written.
|
|
const char* path_; // Path to the file where the minidum should be written.
|
|
|
|
- const struct ucontext* const ucontext_; // also from the signal handler
|
|
+ const ucontext_t* const ucontext_; // also from the signal handler
|
|
#if !defined(__ARM_EABI__) && !defined(__mips__)
|
|
const google_breakpad::fpstate_t* const float_state_; // ditto
|
|
#endif
|
|
--
|
|
2.14.1
|
|
|