mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
47 lines
2.4 KiB
Diff
47 lines
2.4 KiB
Diff
diff -u -r webkitgtk-2.16.5/Source/cmake/OptionsCommon.cmake webkitgtk-2.16.5-gcc7/Source/cmake/OptionsCommon.cmake
|
|
--- webkitgtk-2.16.5/Source/cmake/OptionsCommon.cmake 2017-05-06 10:48:27.000000000 +0200
|
|
+++ webkitgtk-2.16.5-gcc7/Source/cmake/OptionsCommon.cmake 2017-06-27 13:15:26.858090686 +0200
|
|
@@ -38,7 +38,9 @@
|
|
define_property(TARGET PROPERTY FOLDER INHERITED BRIEF_DOCS "folder" FULL_DOCS "IDE folder name")
|
|
|
|
if (COMPILER_IS_GCC_OR_CLANG)
|
|
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-expansion-to-defined -Wno-implicit-fallthrough")
|
|
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fno-exceptions -fno-strict-aliasing")
|
|
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-expansion-to-defined -Wno-implicit-fallthrough")
|
|
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-exceptions -fno-strict-aliasing -fno-rtti")
|
|
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++1y")
|
|
endif ()
|
|
diff -u -r webkitgtk-2.16.5/Source/WTF/wtf/text/StringImpl.h webkitgtk-2.16.5-gcc7/Source/WTF/wtf/text/StringImpl.h
|
|
--- webkitgtk-2.16.5/Source/WTF/wtf/text/StringImpl.h 2017-02-20 17:20:15.000000000 +0100
|
|
+++ webkitgtk-2.16.5-gcc7/Source/WTF/wtf/text/StringImpl.h 2017-06-27 13:13:57.801527350 +0200
|
|
@@ -581,29 +581,7 @@
|
|
// FIXME: Does this really belong in StringImpl?
|
|
template <typename T> static void copyChars(T* destination, const T* source, unsigned numCharacters)
|
|
{
|
|
- if (numCharacters == 1) {
|
|
- *destination = *source;
|
|
- return;
|
|
- }
|
|
-
|
|
- if (numCharacters <= s_copyCharsInlineCutOff) {
|
|
- unsigned i = 0;
|
|
-#if (CPU(X86) || CPU(X86_64))
|
|
- const unsigned charsPerInt = sizeof(uint32_t) / sizeof(T);
|
|
-
|
|
- if (numCharacters > charsPerInt) {
|
|
- unsigned stopCount = numCharacters & ~(charsPerInt - 1);
|
|
-
|
|
- const uint32_t* srcCharacters = reinterpret_cast<const uint32_t*>(source);
|
|
- uint32_t* destCharacters = reinterpret_cast<uint32_t*>(destination);
|
|
- for (unsigned j = 0; i < stopCount; i += charsPerInt, ++j)
|
|
- destCharacters[j] = srcCharacters[j];
|
|
- }
|
|
-#endif
|
|
- for (; i < numCharacters; ++i)
|
|
- destination[i] = source[i];
|
|
- } else
|
|
- memcpy(destination, source, numCharacters * sizeof(T));
|
|
+ memcpy(destination, source, numCharacters * sizeof(T));
|
|
}
|
|
|
|
ALWAYS_INLINE static void copyChars(UChar* destination, const LChar* source, unsigned numCharacters)
|