mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
34 lines
1.3 KiB
Diff
34 lines
1.3 KiB
Diff
--- autofs-5.0.4/modules/cyrus-sasl.c~ 2009-01-11 17:18:55.000000000 +0100
|
|
+++ autofs-5.0.4/modules/cyrus-sasl.c 2009-01-11 17:18:55.000000000 +0100
|
|
@@ -66,6 +66,15 @@
|
|
#endif
|
|
#endif
|
|
|
|
+/**
|
|
+ * The type of a principal is different for MIT Krb5 and Heimdal.
|
|
+ * These macros are provided by Heimdal, and introduced here for MIT.
|
|
+ */
|
|
+#ifndef krb5_realm_length
|
|
+#define krb5_realm_length(r) ((r).length)
|
|
+#define krb5_realm_data(r) ((r).data)
|
|
+#endif
|
|
+
|
|
/*
|
|
* Once a krb5 credentials cache is setup, we need to set the KRB5CCNAME
|
|
* environment variable so that the library knows where to find it.
|
|
@@ -451,11 +460,11 @@
|
|
|
|
/* setup a principal for the ticket granting service */
|
|
ret = krb5_build_principal_ext(ctxt->krb5ctxt, &tgs_princ,
|
|
- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->length,
|
|
- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->data,
|
|
+ krb5_realm_length(*krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)),
|
|
+ krb5_realm_data(*krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)),
|
|
strlen(KRB5_TGS_NAME), KRB5_TGS_NAME,
|
|
- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->length,
|
|
- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->data,
|
|
+ krb5_realm_length(*krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)),
|
|
+ krb5_realm_data(*krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)),
|
|
0);
|
|
if (ret) {
|
|
error(logopt,
|