mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
29 lines
1,007 B
Diff
29 lines
1,007 B
Diff
--- dhcp-3.1.2p1/client/scripts/linux_orig 2006-07-22 04:24:16.000000000 +0200
|
|
+++ dhcp-3.1.2p1/client/scripts/linux 2009-07-20 18:20:54.000000000 +0200
|
|
@@ -133,7 +133,7 @@
|
|
if [ x$old_ip_address != x ] && [ x$old_ip_address != x$new_ip_address ]; then
|
|
# IP address changed. Bringing down the interface will delete all routes,
|
|
# and clear the ARP cache.
|
|
- ifconfig $interface inet 0 down
|
|
+ ifconfig $interface inet 0
|
|
|
|
fi
|
|
if [ x$old_ip_address = x ] || [ x$old_ip_address != x$new_ip_address ] || \
|
|
@@ -168,7 +168,7 @@
|
|
fi
|
|
if [ x$old_ip_address != x ]; then
|
|
# Shut down interface, which will delete routes and clear arp cache.
|
|
- ifconfig $interface inet 0 down
|
|
+ ifconfig $interface inet 0
|
|
fi
|
|
if [ x$alias_ip_address != x ]; then
|
|
ifconfig $interface:0 inet $alias_ip_address $alias_subnet_arg
|
|
@@ -201,7 +201,7 @@
|
|
make_resolv_conf
|
|
exit_with_hooks 0
|
|
fi
|
|
- ifconfig $interface inet 0 down
|
|
+ ifconfig $interface inet 0
|
|
exit_with_hooks 1
|
|
fi
|
|
|