PKGBUILDs/extra/handbrake/handbrake-libmp4v2.patch
2009-10-09 21:23:22 -05:00

32 lines
1.7 KiB
Diff

diff -uNr HandBrake.orig/contrib/Jamfile HandBrake/contrib/Jamfile
--- HandBrake.orig/contrib/Jamfile 2007-10-24 14:12:36.000000000 +0100
+++ HandBrake/contrib/Jamfile 2007-10-24 14:15:47.000000000 +0100
@@ -199,7 +199,7 @@
{
cd `dirname $(>)` && CONTRIB=`pwd` &&
rm -rf mpeg4ip && tar xzf mpeg4ip.tar.gz && cd mpeg4ip &&
- patch -p1 < ../patch-mpeg4ip.patch && patch -p0 < ../patch-mpeg4ip-pascal-str.patch &&
+ patch -p1 < ../patch-mpeg4ip.patch && patch -p1 < ../patch_mpeg4ip_faac.patch && patch -p0 < ../patch-mpeg4ip-pascal-str.patch &&
./bootstrap --cache-file=$CONTRIB/config.cache --disable-mp3lame --disable-faac --disable-x264 --disable-server --disable-player &&
make -C lib/mp4v2 libmp4v2.la && cp lib/mp4v2/.libs/libmp4v2.a $CONTRIB/lib &&
cp mpeg4ip_config.h include/mpeg4ip.h include/mpeg4ip_version.h \
diff -uNr HandBrake.orig/contrib/patch_mpeg4ip_faac.patch HandBrake/contrib/patch_mpeg4ip_faac.patch
--- HandBrake.orig/contrib/patch_mpeg4ip_faac.patch 1970-01-01 01:00:00.000000000 +0100
+++ HandBrake/contrib/patch_mpeg4ip_faac.patch 2007-10-24 14:14:08.000000000 +0100
@@ -0,0 +1,16 @@
+diff -ruN mpeg4ip/bootstrap mpeg4ip.work/bootstrap
+--- mpeg4ip/bootstrap 2005-10-13 14:09:41.000000000 -0600
++++ mpeg4ip.work/bootstrap 2007-02-13 16:03:30.236971291 -0700
+@@ -47,9 +47,9 @@
+ #
+ if test $target_system = "Linux"; then
+ have_faac=no
+- if which faac >/dev/null 2>/dev/null; then
+- have_faac=yes
+- fi
++# if which faac >/dev/null 2>/dev/null; then
++# have_faac=yes
++# fi
+
+ if test $have_faac = "yes"; then
+ # we have lame and faac - see if faac is built with mp4 support