PKGBUILDs/extra/kdelibs3/kde-3.5-1002164.patch
2009-10-09 21:23:22 -05:00

557 lines
20 KiB
Diff

Index: kate/data/cmake.xml
===================================================================
--- kate/data/cmake.xml (.../tags/KDE/3.5.10/kdelibs) (Revision 1004024)
+++ kate/data/cmake.xml (.../branches/KDE/3.5/kdelibs) (Revision 1004024)
@@ -1,13 +1,34 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE language SYSTEM "language.dtd">
-<!-- Author: Alexander Neundorf <neundorf@kde.org> //-->
-<!-- cmake 2.0.3 syntax highlighting -->
-<!-- dsKeyword, dsDataType, dsDecVal, dsBaseN, dsFloat, dsChar, dsString, dsComment, dsOthers, new in KDE 3.3: dsAlert, dsFunction, dsRegionMarker, dsError -->
-<language name="CMake" version="1.03" kateversion="2.4" section="Other" extensions="CMakeLists.txt;*.cmake;" mimetype="">
+<!--
+ This file is part of KDE's kate project.
+
+ Copyright 2004 Alexander Neundorf (neundorf@kde.org)
+ Copyright 2005 Dominik Haumann (dhdev@gmx.de)
+ Copyright 2007,2008 Matthew Woehlke (mw_triad@users.sourceforge.net)
+
+ **********************************************************************
+ * This library is free software; you can redistribute it and/or *
+ * modify it under the terms of the GNU Lesser General Public *
+ * License as published by the Free Software Foundation; either *
+ * version 2 of the License, or (at your option) any later version. *
+ * *
+ * This library is distributed in the hope that it will be useful, *
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of *
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU *
+ * Lesser General Public License for more details. *
+ * *
+ * You should have received a copy of the GNU Lesser General Public *
+ * License along with this library; if not, write to the *
+ * Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor, *
+ * Boston, MA 02110-1301, USA. *
+ **********************************************************************
+ -->
+<!-- generated for "cmake version 2.6-patch 2" -->
+<language name="CMake" version="1.06" kateversion="2.4" section="Other" extensions="CMakeLists.txt;*.cmake;" mimetype="" author="Alexander Neundorf (neundorf@kde.org)" license="LGPL">
<highlighting>
<list name = "commands">
- <item> ABSTRACT_FILES </item>
<item> ADD_CUSTOM_COMMAND </item>
<item> ADD_CUSTOM_TARGET </item>
<item> ADD_DEFINITIONS </item>
@@ -17,18 +38,26 @@
<item> ADD_SUBDIRECTORY </item>
<item> ADD_TEST </item>
<item> AUX_SOURCE_DIRECTORY </item>
+ <item> BREAK </item>
<item> BUILD_COMMAND </item>
<item> BUILD_NAME </item>
<item> CMAKE_MINIMUM_REQUIRED </item>
+ <item> CMAKE_POLICY </item>
<item> CONFIGURE_FILE </item>
<item> CREATE_TEST_SOURCELIST </item>
+ <item> DEFINE_PROPERTY </item>
<item> ELSE </item>
<item> ELSEIF </item>
+ <item> ENABLE_LANGUAGE </item>
<item> ENABLE_TESTING </item>
<item> ENDFOREACH </item>
+ <item> ENDFUNCTION </item>
<item> ENDIF </item>
<item> ENDMACRO </item>
+ <item> ENDWHILE </item>
+ <item> EXECUTE_PROCESS </item>
<item> EXEC_PROGRAM </item>
+ <item> EXPORT </item>
<item> EXPORT_LIBRARY_DEPENDENCIES </item>
<item> FILE </item>
<item> FIND_FILE </item>
@@ -38,11 +67,14 @@
<item> FIND_PROGRAM </item>
<item> FLTK_WRAP_UI </item>
<item> FOREACH </item>
+ <item> FUNCTION </item>
<item> GET_CMAKE_PROPERTY </item>
<item> GET_DIRECTORY_PROPERTY </item>
<item> GET_FILENAME_COMPONENT </item>
+ <item> GET_PROPERTY </item>
<item> GET_SOURCE_FILE_PROPERTY </item>
<item> GET_TARGET_PROPERTY </item>
+ <item> GET_TEST_PROPERTY </item>
<item> IF </item>
<item> INCLUDE </item>
<item> INCLUDE_DIRECTORIES </item>
@@ -61,6 +93,7 @@
<item> MACRO </item>
<item> MAKE_DIRECTORY </item>
<item> MARK_AS_ADVANCED </item>
+ <item> MATH </item>
<item> MESSAGE </item>
<item> OPTION </item>
<item> OUTPUT_REQUIRED_FILES </item>
@@ -69,14 +102,14 @@
<item> QT_WRAP_UI </item>
<item> REMOVE </item>
<item> REMOVE_DEFINITIONS </item>
+ <item> RETURN </item>
<item> SEPARATE_ARGUMENTS </item>
<item> SET </item>
<item> SET_DIRECTORY_PROPERTIES </item>
+ <item> SET_PROPERTY </item>
<item> SET_SOURCE_FILES_PROPERTIES </item>
<item> SET_TARGET_PROPERTIES </item>
<item> SITE_NAME </item>
- <item> SOURCE_FILES </item>
- <item> SOURCE_FILES_REMOVE </item>
<item> SOURCE_GROUP </item>
<item> STRING </item>
<item> SUBDIRS </item>
@@ -84,14 +117,14 @@
<item> TARGET_LINK_LIBRARIES </item>
<item> TRY_COMPILE </item>
<item> TRY_RUN </item>
- <item> USE_MANGLED_MESA </item>
+ <item> UNSET </item>
<item> UTILITY_SOURCE </item>
<item> VARIABLE_REQUIRES </item>
+ <item> VARIABLE_WATCH </item>
<item> VTK_MAKE_INSTANTIATOR </item>
<item> VTK_WRAP_JAVA </item>
<item> VTK_WRAP_PYTHON </item>
<item> VTK_WRAP_TCL </item>
- <item> WRAP_EXCLUDE_FILES </item>
<item> WRITE_FILE </item>
</list>
@@ -106,10 +139,13 @@
<item> ARGS </item>
<item> ASCII </item>
<item> BEFORE </item>
+ <item> BRIEF_DOCS </item>
+ <item> BUNDLE </item>
<item> CACHE </item>
<item> CACHE_VARIABLES </item>
<item> CLEAR </item>
<item> CMAKE_FLAGS </item>
+ <item> CMAKE_FIND_ROOT_PATH_BOTH </item>
<item> CODE </item>
<item> COMMAND </item>
<item> COMMANDS </item>
@@ -118,45 +154,62 @@
<item> COMPARE </item>
<item> COMPILE_FLAGS </item>
<item> COMPONENT </item>
+ <item> COMPONENTS </item>
<item> CONFIGURATIONS </item>
+ <item> CONFIGURE </item>
<item> COPYONLY </item>
<item> DEFINED </item>
<item> DEFINE_SYMBOL </item>
+ <item> DEFINITION </item>
<item> DEPENDS </item>
<item> DESTINATION </item>
+ <item> DIRECTORY </item>
<item> DIRECTORY_PERMISSIONS </item>
<item> DOC </item>
+ <item> DOWNLOAD </item>
<item> EQUAL </item>
<item> ESCAPE_QUOTES </item>
+ <item> EXACT </item>
<item> EXCLUDE </item>
<item> EXCLUDE_FROM_ALL </item>
<item> EXISTS </item>
- <item> EXPORT_MACRO </item>
+ <item> EXPORT </item>
+ <item> EXPR </item>
<item> EXT </item>
<item> EXTRA_INCLUDE </item>
<item> FATAL_ERROR </item>
<item> FILE </item>
<item> FILES </item>
<item> FILE_PERMISSIONS </item>
+ <item> FILES_MATCHING </item>
<item> FORCE </item>
- <item> FUNCTION </item>
+ <item> FRAMEWORK </item>
+ <item> FULL_DOCS </item>
<item> GENERATED </item>
+ <item> GET </item>
<item> GLOB </item>
<item> GLOB_RECURSE </item>
+ <item> GLOBAL </item>
<item> GREATER </item>
<item> GROUP_SIZE </item>
<item> HEADER_FILE_ONLY </item>
<item> HEADER_LOCATION </item>
+ <item> HINTS </item>
<item> IMMEDIATE </item>
<item> INCLUDES </item>
<item> INCLUDE_DIRECTORIES </item>
<item> INCLUDE_INTERNALS </item>
<item> INCLUDE_REGULAR_EXPRESSION </item>
+ <item> INHERITED </item>
<item> INTERNAL </item>
+ <item> IS_ABSOLUTE </item>
+ <item> IS_NEWER_THAN </item>
+ <item> LENGTH </item>
<item> LESS </item>
<item> LIBRARY </item>
<item> LINK_DIRECTORIES </item>
<item> LINK_FLAGS </item>
+ <item> LINK_INTERFACE_LIBRARIES </item>
<item> LOCATION </item>
<item> MACOSX_BUNDLE </item>
<item> MACROS </item>
@@ -167,19 +220,33 @@
<item> MATCHES </item>
<item> MODULE </item>
<item> NAME </item>
+ <item> NAMELINK_ONLY </item>
+ <item> NAMELINK_SKIP </item>
+ <item> NAMES </item>
<item> NAME_WE </item>
<item> NOT </item>
<item> NOTEQUAL </item>
+ <item> NO_CMAKE_PATH </item>
+ <item> NO_CMAKE_ENVIRONMENT_PATH </item>
+ <item> NO_CMAKE_FIND_ROOT_PATH </item>
+ <item> NO_DEFAULT_PATH </item>
+ <item> NO_MODULE </item>
<item> NO_SYSTEM_PATH </item>
+ <item> NO_SYSTEM_ENVIRONMENT_PATH </item>
<item> OBJECT_DEPENDS </item>
+ <item> ONLY_CMAKE_FIND_ROOT_PATH </item>
<item> OPTIONAL </item>
<item> OR </item>
<item> OUTPUT </item>
<item> OUTPUT_VARIABLE </item>
+ <item> PARENT_SCOPE </item>
<item> PATH </item>
<item> PATHS </item>
+ <item> PATH_SUFFIXES </item>
<item> PATTERN </item>
<item> PERMISSIONS </item>
+ <item> POLICY </item>
+ <item> POP </item>
<item> POST_BUILD </item>
<item> POST_INSTALL_SCRIPT </item>
<item> PREFIX </item>
@@ -187,40 +254,60 @@
<item> PRE_BUILD </item>
<item> PRE_INSTALL_SCRIPT </item>
<item> PRE_LINK </item>
+ <item> PRIVATE_HEADER </item>
<item> PROGRAM </item>
<item> PROGRAMS </item>
<item> PROGRAM_ARGS </item>
<item> PROPERTIES </item>
+ <item> PUBLIC_HEADER </item>
+ <item> PUSH </item>
<item> QUIET </item>
+ <item> RANDOM </item>
<item> RANGE </item>
<item> READ </item>
<item> REGEX </item>
<item> REGULAR_EXPRESSION </item>
+ <item> RELATIVE_PATH </item>
+ <item> REMOVE </item>
+ <item> REMOVE_RECURSE </item>
<item> RENAME </item>
<item> REPLACE </item>
<item> REQUIRED </item>
+ <item> RESOURCE </item>
<item> RETURN_VALUE </item>
<item> RUNTIME </item>
<item> RUNTIME_DIRECTORY </item>
<item> SCRIPT </item>
<item> SEND_ERROR </item>
<item> SHARED </item>
+ <item> SOURCE </item>
<item> SOURCES </item>
<item> STATIC </item>
<item> STATUS </item>
+ <item> STRIP </item>
+ <item> STRINGS </item>
<item> STREQUAL </item>
<item> STRGREATER </item>
<item> STRLESS </item>
<item> SUFFIX </item>
+ <item> SUBSTRING </item>
<item> TARGET </item>
<item> TARGETS </item>
+ <item> TIMEOUT </item>
<item> TOLOWER </item>
<item> TOUPPER </item>
+ <item> TO_CMAKE_PATH </item>
+ <item> TO_NATIVE_PATH </item>
<item> USE_SOURCE_PERMISSIONS </item>
<item> VAR </item>
+ <item> VARIABLE </item>
<item> VARIABLES </item>
<item> VERSION </item>
+ <item> VERSION_LESS </item>
+ <item> VERSION_EQUAL </item>
+ <item> VERSION_GREATER </item>
<item> WIN32 </item>
+ <item> WORKING_DIRECTORY </item>
<item> WRAP_EXCLUDE </item>
<item> WRITE </item>
</list>
Index: kioslave/ftp/ftp.cc
===================================================================
--- kioslave/ftp/ftp.cc (.../tags/KDE/3.5.10/kdelibs) (Revision 1004024)
+++ kioslave/ftp/ftp.cc (.../branches/KDE/3.5/kdelibs) (Revision 1004024)
@@ -876,7 +876,7 @@
// The usual answer is '227 Entering Passive Mode. (160,39,200,55,6,245)'
// but anonftpd gives '227 =160,39,200,55,6,245'
int i[6];
- char *start = strchr(ftpResponse(3), '(');
+ const char *start = strchr(ftpResponse(3), '(');
if ( !start )
start = strchr(ftpResponse(3), '=');
if ( !start ||
@@ -931,7 +931,7 @@
return ERR_INTERNAL;
}
- char *start = strchr(ftpResponse(3), '|');
+ const char *start = strchr(ftpResponse(3), '|');
if ( !start || sscanf(start, "|||%d|", &portnum) != 1)
return ERR_INTERNAL;
Index: kinit/start_kdeinit.c
===================================================================
--- kinit/start_kdeinit.c (.../tags/KDE/3.5.10/kdelibs) (Revision 1004024)
+++ kinit/start_kdeinit.c (.../branches/KDE/3.5/kdelibs) (Revision 1004024)
@@ -44,7 +44,7 @@
{
char buf[ 1024 ];
int procfile;
- sprintf( buf, "/proc/%d/oom_adj", pid );
+ sprintf( buf, "/proc/%d/stat", pid );
if( !enable ) {
/* Be paranoid and check that the pid we got from the pipe
belongs to this user. */
@@ -52,6 +52,7 @@
if( lstat( buf, &st ) < 0 || st.st_uid != getuid())
return 0;
}
+ sprintf( buf, "/proc/%d/oom_adj", pid );
procfile = open( buf, O_WRONLY );
if( procfile >= 0 ) {
if( enable )
Index: kio/kio/configure.in.in
===================================================================
--- kio/kio/configure.in.in (.../tags/KDE/3.5.10/kdelibs) (Revision 1004024)
+++ kio/kio/configure.in.in (.../branches/KDE/3.5/kdelibs) (Revision 1004024)
@@ -139,8 +139,30 @@
AC_LANG_RESTORE
])
- if test "$kde_cv_have_inotify" = "yes" ; then
+ AC_CACHE_VAL(kde_cv_have_sys_inotify,
+ [
+ kde_cv_have_sys_inotify=no
+ AC_LANG_SAVE
+ AC_LANG_C
+
+ AC_TRY_COMPILE(
+ [
+#include <sys/inotify.h>
+ ],
+ [
+#ifndef IN_ALL_EVENTS
+#error no inotify notification
+#endif
+ ],kde_cv_have_sys_inotify=yes,kde_cv_have_sys_inotify=no)
+
+ AC_LANG_RESTORE
+ ])
+
+ if test "$kde_cv_have_inotify" = "yes" -o "$kde_cv_have_sys_inotify" = "yes"; then
AC_DEFINE_UNQUOTED(HAVE_INOTIFY, 1, [Define if your system has Linux Inode Notification])
+ if test "$kde_cv_have_sys_inotify" = "yes"; then
+ AC_DEFINE_UNQUOTED(HAVE_SYS_INOTIFY, 1, [Define if your system has glibc support for inotify])
+ fi
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)
Index: kio/kio/kdirwatch.cpp
===================================================================
--- kio/kio/kdirwatch.cpp (.../tags/KDE/3.5.10/kdelibs) (Revision 1004024)
+++ kio/kio/kdirwatch.cpp (.../branches/KDE/3.5/kdelibs) (Revision 1004024)
@@ -64,11 +64,13 @@
// debug
#include <sys/ioctl.h>
-#ifdef HAVE_INOTIFY
+#ifdef HAVE_SYS_INOTIFY
+#include <sys/inotify.h>
+#include <fcntl.h>
+#elif HAVE_INOTIFY
#include <unistd.h>
#include <fcntl.h>
#include <sys/syscall.h>
-#include <linux/types.h>
// Linux kernel headers are documented to not compile
#define _S390_BITOPS_H
#include <linux/inotify.h>
@@ -87,7 +89,9 @@
{
return syscall (__NR_inotify_rm_watch, fd, wd);
}
+#endif
+#ifdef HAVE_INOTIFY
#ifndef IN_ONLYDIR
#define IN_ONLYDIR 0x01000000
#endif
@@ -99,7 +103,6 @@
#ifndef IN_MOVE_SELF
#define IN_MOVE_SELF 0x00000800
#endif
-
#endif
#include <sys/utsname.h>
Index: kdecore/kstringhandler.cpp
===================================================================
--- kdecore/kstringhandler.cpp (.../tags/KDE/3.5.10/kdelibs) (Revision 1004024)
+++ kdecore/kstringhandler.cpp (.../branches/KDE/3.5/kdelibs) (Revision 1004024)
@@ -558,7 +558,7 @@
QString result;
const QChar *unicode = str.unicode();
for ( uint i = 0; i < str.length(); ++i )
- result += ( unicode[ i ].unicode() < 0x21 ) ? unicode[ i ] :
+ result += ( unicode[ i ].unicode() <= 0x21 ) ? unicode[ i ] :
QChar( 0x1001F - unicode[ i ].unicode() );
return result;
Index: khtml/html/htmltokenizer.cpp
===================================================================
--- khtml/html/htmltokenizer.cpp (.../tags/KDE/3.5.10/kdelibs) (Revision 1004024)
+++ khtml/html/htmltokenizer.cpp (.../branches/KDE/3.5/kdelibs) (Revision 1004024)
@@ -736,7 +736,7 @@
#ifdef TOKEN_DEBUG
kdDebug( 6036 ) << "unknown entity!" << endl;
#endif
- checkBuffer(10);
+ checkBuffer(11);
// ignore the sequence, add it to the buffer as plaintext
*dest++ = '&';
for(unsigned int i = 0; i < cBufferPos; i++)
Index: khtml/rendering/table_layout.cpp
===================================================================
--- khtml/rendering/table_layout.cpp (.../tags/KDE/3.5.10/kdelibs) (Revision 1004024)
+++ khtml/rendering/table_layout.cpp (.../branches/KDE/3.5/kdelibs) (Revision 1004024)
@@ -297,7 +297,8 @@
#endif
for ( int i = 0; available > 0 && i < nEffCols; i++ ) {
if ( width[i].isPercent() ) {
- int w = base * width[i].value() / totalPercent;
+ // totalPercent may be 0 below if all %-width specifed are 0%. (#172557)
+ int w = totalPercent ? base * width[i].value() / totalPercent : 0;
available -= w;
calcWidth[i] = w;
}
@@ -313,7 +314,8 @@
for ( int i = 0; available > 0 && i < nEffCols; i++ ) {
if ( width[i].isVariable() ) {
- int w = available / totalVariable;
+ // totalVariable may be 0 below if all the variable widths specified are 0.
+ int w = totalVariable ? available / totalVariable : 0;
available -= w;
calcWidth[i] = w;
totalVariable--;
Index: kdoctools/customization/pt-BR/user.entities
===================================================================
--- kdoctools/customization/pt-BR/user.entities (.../tags/KDE/3.5.10/kdelibs) (Revision 1004024)
+++ kdoctools/customization/pt-BR/user.entities (.../branches/KDE/3.5/kdelibs) (Revision 1004024)
@@ -17,7 +17,7 @@
<!ENTITY Esc "<keycap>Esc</keycap>">
<!ENTITY etc "<abbrev>etc</abbrev>">
<!ENTITY ex "<abbrev>por exemplo</abbrev>">
-<!ENTITY FAQ "Perguntas Mais Freqüentes (do inglês <acronym>FAQ</acronym>)">
+<!ENTITY FAQ "Perguntas mais freqüentes (do inglês <acronym>FAQ</acronym>)">
<!ENTITY HTML '<acronym>HTML</acronym>'>
<!ENTITY ie "isto é">
<!ENTITY infocenter "<application>Centro de Informações</application>">
@@ -34,7 +34,7 @@
<!ENTITY LMB "botão <mousebutton>esquerdo</mousebutton> do mouse">
<!ENTITY MMB "botão do <mousebutton>meio</mousebutton> do mouse">
<!ENTITY OS "<acronym>Sistema Operacional</acronym>">
-<!ENTITY RMB "botão <mousebutton>direto</mousebutton> do mouse">
+<!ENTITY RMB "botão <mousebutton>direito</mousebutton> do mouse">
<!ENTITY Shift "<keycap>Shift</keycap>">
<!ENTITY systemtray "<application>bandeja do sistema</application>">
<!ENTITY Tab "<keycap>Tab</keycap>">
Index: kdeui/kdatetbl.cpp
===================================================================
--- kdeui/kdatetbl.cpp (.../tags/KDE/3.5.10/kdelibs) (Revision 1004024)
+++ kdeui/kdatetbl.cpp (.../branches/KDE/3.5/kdelibs) (Revision 1004024)
@@ -47,6 +47,7 @@
#include "kdatetbl.h"
#include "kpopupmenu.h"
#include <qdatetime.h>
+#include <qguardedptr.h>
#include <qstring.h>
#include <qpen.h>
#include <qpainter.h>
@@ -310,7 +311,7 @@
painter->setPen(colorGroup().highlight());
painter->setBrush(colorGroup().highlight());
}
- else
+ else
{
painter->setPen(colorGroup().text());
painter->setBrush(colorGroup().text());
@@ -366,7 +367,7 @@
void KDateTable::endOfWeek()
{
setDate(date.addDays(7 - date.dayOfWeek()));
-}
+}
void
KDateTable::keyPressEvent( QKeyEvent *e )
@@ -482,14 +483,14 @@
// old selected date:
temp = posFromDate( date );
// new position and date
- pos = (7 * (row - 1)) + col;
+ pos = (7 * (row - 1)) + col;
QDate clickedDate = dateFromPos( pos );
// set the new date. If it is in the previous or next month, the month will
// automatically be changed, no need to do that manually...
setDate( clickedDate );
- // call updateCell on the old and new selection. If setDate switched to a different
+ // call updateCell on the old and new selection. If setDate switched to a different
// month, these cells will be painted twice, but that's no problem.
updateCell( temp/7+1, temp%7 );
updateCell( row, col );
@@ -1007,7 +1008,10 @@
popup(pos);
repaint();
d->exec = true;
+ const QGuardedPtr<QObject> that = this;
qApp->enter_loop();
+ if ( !that )
+ return QDialog::Rejected;
hide();
return result;
}
Eigenschaftsänderungen: .
___________________________________________________________________
Gelöscht: svn:mergeinfo
Hinzugefügt: svn:externals
+ admin https://svn.kde.org/home/kde/branches/KDE/3.5/kde-common/admin