mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
61 lines
2.6 KiB
Diff
61 lines
2.6 KiB
Diff
diff -Naur lm_sensors-3.1.0/prog/detect/sensors-detect lm_sensors-3.1.0-new/prog/detect/sensors-detect
|
|
--- lm_sensors-3.1.0/prog/detect/sensors-detect 2009-03-03 20:36:33.000000000 -0500
|
|
+++ lm_sensors-3.1.0-new/prog/detect/sensors-detect 2009-03-03 20:52:06.000000000 -0500
|
|
@@ -5282,21 +5282,21 @@
|
|
}
|
|
}
|
|
|
|
- my $have_sysconfig = -d '/etc/sysconfig';
|
|
- printf "Do you want to \%s /etc/sysconfig/lm_sensors? (\%s): ",
|
|
- (-e '/etc/sysconfig/lm_sensors' ? 'overwrite' : 'generate'),
|
|
+ my $have_sysconfig = -d '/etc/conf.d';
|
|
+ printf "Do you want to \%s /etc/conf.d/lm_sensors? (\%s): ",
|
|
+ (-e '/etc/conf.d/lm_sensors' ? 'overwrite' : 'generate'),
|
|
($have_sysconfig ? 'YES/no' : 'yes/NO');
|
|
$_ = <STDIN>;
|
|
if (($have_sysconfig and not m/^\s*n/i) or m/^\s*y/i) {
|
|
unless ($have_sysconfig) {
|
|
- mkdir('/etc/sysconfig', 0777)
|
|
- or die "Sorry, can't create /etc/sysconfig ($!)";
|
|
+ mkdir('/etc/conf.d', 0777)
|
|
+ or die "Sorry, can't create /etc/conf.d ($!)";
|
|
}
|
|
- open(local *SYSCONFIG, ">/etc/sysconfig/lm_sensors")
|
|
- or die "Sorry, can't create /etc/sysconfig/lm_sensors ($!)";
|
|
+ open(local *SYSCONFIG, ">/etc/conf.d/lm_sensors")
|
|
+ or die "Sorry, can't create /etc/conf.d/lm_sensors ($!)";
|
|
print SYSCONFIG "# Generated by sensors-detect on " . scalar localtime() . "\n";
|
|
print SYSCONFIG <<'EOT';
|
|
-# This file is sourced by /etc/init.d/lm_sensors and defines the modules to
|
|
+# This file is sourced by /etc/rc.d/lm_sensors and defines the modules to
|
|
# be loaded/unloaded.
|
|
#
|
|
# The format of this file is a shell script that simply defines variables:
|
|
@@ -5322,13 +5322,13 @@
|
|
}
|
|
close(SYSCONFIG);
|
|
|
|
- print "Copy prog/init/lm_sensors.init to /etc/init.d/lm_sensors\n".
|
|
+ print "Copy prog/init/lm_sensors.init to /etc/rc.d/lm_sensors\n".
|
|
"for initialization at boot time.\n"
|
|
- unless -f "/etc/init.d/lm_sensors";
|
|
+ unless -f "/etc/rc.d/lm_sensors";
|
|
|
|
- if (-x "/sbin/insserv" && -f "/etc/init.d/lm_sensors") {
|
|
- system("/sbin/insserv", "/etc/init.d/lm_sensors");
|
|
- } elsif (-x "/sbin/chkconfig" && -f "/etc/init.d/lm_sensors") {
|
|
+ if (-x "/sbin/insserv" && -f "/etc/rc.d/lm_sensors") {
|
|
+ system("/sbin/insserv", "/etc/rc.d/lm_sensors");
|
|
+ } elsif (-x "/sbin/chkconfig" && -f "/etc/rc.d/lm_sensors") {
|
|
system("/sbin/chkconfig", "lm_sensors", "on");
|
|
if (-x "/sbin/service") {
|
|
system("/sbin/service", "lm_sensors", "start");
|
|
@@ -5377,7 +5377,7 @@
|
|
exit -1;
|
|
}
|
|
|
|
- if (-x "/sbin/service" && -f "/etc/init.d/lm_sensors" &&
|
|
+ if (-x "/sbin/service" && -f "/etc/rc.d/sensors" &&
|
|
-f "/var/lock/subsys/lm_sensors") {
|
|
system("/sbin/service", "lm_sensors", "stop");
|
|
}
|