mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
53 lines
2.4 KiB
Diff
53 lines
2.4 KiB
Diff
diff -Naur squid-2.7.STABLE2-orig/helpers/basic_auth/SMB/Makefile.in squid-2.7.STABLE2/helpers/basic_auth/SMB/Makefile.in
|
|
--- squid-2.7.STABLE2-orig/helpers/basic_auth/SMB/Makefile.in 2007-11-11 20:14:01.000000000 -0500
|
|
+++ squid-2.7.STABLE2/helpers/basic_auth/SMB/Makefile.in 2008-06-09 21:32:52.000000000 -0400
|
|
@@ -268,7 +268,7 @@
|
|
sysconfdir = @sysconfdir@
|
|
target_alias = @target_alias@
|
|
SMB_AUTH_HELPER = smb_auth.sh
|
|
-SAMBAPREFIX = /usr/local/samba
|
|
+SAMBAPREFIX = /usr
|
|
SMB_AUTH_HELPER_PATH = $(libexecdir)/$(SMB_AUTH_HELPER)
|
|
libexec_SCRIPTS = $(SMB_AUTH_HELPER)
|
|
smb_auth_CFLAGS = -DSAMBAPREFIX=\"$(SAMBAPREFIX)\" -DHELPERSCRIPT=\"$(SMB_AUTH_HELPER_PATH)\"
|
|
diff -Naur squid-2.7.STABLE2-orig/src/Makefile.in squid-2.7.STABLE2/src/Makefile.in
|
|
--- squid-2.7.STABLE2-orig/src/Makefile.in 2008-01-02 20:16:40.000000000 -0500
|
|
+++ squid-2.7.STABLE2/src/Makefile.in 2008-06-09 21:34:39.000000000 -0400
|
|
@@ -653,13 +653,13 @@
|
|
DEFAULT_CONFIG_FILE = $(sysconfdir)/squid.conf
|
|
DEFAULT_MIME_TABLE = $(sysconfdir)/mime.conf
|
|
DEFAULT_DNSSERVER = $(libexecdir)/`echo dnsserver | sed '$(transform);s/$$/$(EXEEXT)/'`
|
|
-DEFAULT_LOG_PREFIX = $(localstatedir)/logs
|
|
+DEFAULT_LOG_PREFIX = $(localstatedir)/log/squid
|
|
DEFAULT_CACHE_LOG = $(DEFAULT_LOG_PREFIX)/cache.log
|
|
DEFAULT_ACCESS_LOG = $(DEFAULT_LOG_PREFIX)/access.log
|
|
DEFAULT_STORE_LOG = $(DEFAULT_LOG_PREFIX)/store.log
|
|
-DEFAULT_PID_FILE = $(DEFAULT_LOG_PREFIX)/squid.pid
|
|
+DEFAULT_PID_FILE = $(localstatedir)/run/squid.pid
|
|
DEFAULT_NETDB_FILE = $(DEFAULT_LOG_PREFIX)/netdb.state
|
|
-DEFAULT_SWAP_DIR = $(localstatedir)/cache
|
|
+DEFAULT_SWAP_DIR = $(localstatedir)/cache/squid
|
|
DEFAULT_PINGER = $(libexecdir)/`echo pinger | sed '$(transform);s/$$/$(EXEEXT)/'`
|
|
DEFAULT_UNLINKD = $(libexecdir)/`echo unlinkd | sed '$(transform);s/$$/$(EXEEXT)/'`
|
|
DEFAULT_DISKD = $(libexecdir)/`echo diskd-daemon | sed '$(transform);s/$$/$(EXEEXT)/'`
|
|
diff -Naur squid-2.7.STABLE2-orig/src/cf.data.pre squid-2.7.STABLE2/src/cf.data.pre
|
|
--- squid-2.7.STABLE2-orig/src/cf.data.pre 2008-05-31 16:49:45.000000000 -0400
|
|
+++ squid-2.7.STABLE2/src/cf.data.pre 2008-06-09 21:35:43.000000000 -0400
|
|
@@ -3749,7 +3749,7 @@
|
|
|
|
NAME: cache_effective_user
|
|
TYPE: string
|
|
-DEFAULT: nobody
|
|
+DEFAULT: proxy
|
|
LOC: Config.effectiveUser
|
|
DOC_START
|
|
If you start Squid as root, it will change its effective/real
|
|
@@ -3763,7 +3763,7 @@
|
|
|
|
NAME: cache_effective_group
|
|
TYPE: string
|
|
-DEFAULT: none
|
|
+DEFAULT: proxy
|
|
LOC: Config.effectiveGroup
|
|
DOC_START
|
|
If you want Squid to run with a specific GID regardless of
|